Tweens Class
A group of Tween
s. This class is called Group
in the tween.js library.
note Unlike tween.js, we do NOT create any global instances of this class
like the global object TWEEN
in tween.js. You must create an instance of this class, and then create Tweens by
calling Tweens.create or by calling new Tween()
and pass your Group as its first argument.
see The tween.js users guide
Methods
Name | Description | |
---|---|---|
constructor(): Tweens | ||
add(tween: Tween): void | ||
create(from: any, opts?: { delay?: number, duration: number, easing?: EasingFunction, interpolation?: InterpolationFunction, onComplete?: TweenCallback, onUpdate: UpdateCallback, start?: boolean, to: any }): Tween | Create a new Tween owned by this Group. | |
getAll(): any[] | ||
nextId(): number | ||
remove(tween: Tween): void | ||
removeAll(): void | ||
update(time?: number, preserve?: boolean): boolean |
Defined in
- core/common/src/Tween.ts Line 32
Last Updated: 20 June, 2023