MassPropertiesResponseProps Interface
Information returned from the back end to the front end holding the result of the mass properties calculation.
extensions
Properties
Name | Type | Description | |
---|---|---|---|
area | undefined | number | Surface area of solids and surfaces when MassPropertiesOperation.AccumulateVolumes or MassPropertiesOperation.AccumulateAreas requested | |
centroid | undefined | XYZProps | Centroid of geometry | |
ixy | undefined | number | Product of inertia with respect to xy plane | |
ixz | undefined | number | Product of inertia with respect to xz plane | |
iyz | undefined | number | Product of inertia with respect to yz plane | |
length | undefined | number | Length of curves or perimeter of planar regions when MassPropertiesOperation.AccumulateAreas or MassPropertiesOperation.AccumulateLength requested | |
moments | undefined | XYZProps | Moments of inertia | |
perimeter | undefined | number | Perimeter of surfaces and planar regions when MassPropertiesOperation.AccumulateAreas requested | |
status | BentleyStatus | Success if requested MassPropertiesOperation could be evaluated for the specified elements | |
volume | undefined | number | Volume of solids when MassPropertiesOperation.AccumulateVolumes requested |
Defined in
Last Updated: 20 June, 2023