SubjectProps Interface
Properties of a Subject
extensions
Extends
Properties
Name | Type | Description | |
---|---|---|---|
description | undefined | string |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName | string | ElementProps | The full name of the ECClass for this entity, in the form "Schema:ClassName" |
code | CodeProps | ElementProps | The Code for this element |
federationGuid | undefined | string | ElementProps | A FederationGuid assigned to this element. |
id | undefined | string | ElementProps | The Id of the entity. |
isInstanceOfEntity Readonly | undefined | undefined | ElementProps | A non-existent property used to discriminate between EntityProps and Entity. |
jsonProperties | undefined | any | ElementProps | Optional json properties of this element. |
model | string | ElementProps | The Id of the Model containing this element |
parent | undefined | RelatedElementProps | ElementProps | The Parent of this element, if defined. |
userLabel | undefined | string | ElementProps | A user-assigned label for this element. |
Defined in
- core/common/src/ElementProps.ts Line 267
Last Updated: 20 June, 2023