ProjectionProps Interface
This class encapsulates the projection of the CRS. The projection relies on a projection method and a set of projection parameters specific to projection method selected.
extensions
Implemented by
Properties
Name | Type | Description | |
---|---|---|---|
affine | undefined | AffineTransformProps | The definition of the affine post-transformation for Transverse Mercator and Lambert Conformal Conic with post-affine projections | |
azimuth | undefined | number | Azimuth. | |
centralMeridian | undefined | number | The Central Meridian. | |
centralPointLatitude | undefined | number | Latitude of the central point. | |
centralPointLongitude | undefined | number | Longitude of the central point. | |
danishSystem34Region | undefined | DanishSystem34Region | The Danish zone for Danish projections. | |
elevationAboveGeoid | undefined | number | The elevation of the origin of the projection above the geoid. | |
falseEasting | undefined | number | The False Easting of the projection. | |
falseNorthing | undefined | number | The False Northing of the projection. | |
geoidSeparation | undefined | number | The geoid separation. | |
hemisphere | undefined | HemisphereEnum | The hemisphere for Universal Transverse Mercator projection. | |
latitudeOfOrigin | undefined | number | The latitude of origin of the projection. | |
longitudeOfOrigin | undefined | number | Longitude of origin of the projection. | |
method | ProjectionMethod | The projection method. | |
point1Latitude | undefined | number | Latitude of the first alignment point for some Oblique Mercator and Krovak projections. | |
point1Longitude | undefined | number | Longitude of the first alignment point for some Oblique Mercator and Krovak projections. | |
point2Latitude | undefined | number | Latitude of the second alignment point for some Oblique Mercator projections. | |
point2Longitude | undefined | number | Longitude of the second alignment point for some Oblique Mercator projections. | |
scaleFactor | undefined | number | The scale reduction factor applied at origin. | |
standardParallel | undefined | number | Standard parallel for projection that only use one. | |
standardParallel1 | undefined | number | The first standard parallel at which the cone crosses the ellipsoid. | |
standardParallel2 | undefined | number | The second standard parallel at which the cone crosses the ellipsoid. | |
zoneNumber | undefined | number | The UTM zone number. |
Defined in
Last Updated: 20 June, 2023