TerrainSettings Class
Normalized version of TerrainProps for which provider has been validated and default values of all members are used.
Methods
Name | Description | |
---|---|---|
constructor(providerName: string = "CesiumWorldTerrain", exaggeration: number = 1.0, applyLighting: boolean = false, heightOrigin: number = 0.0, heightOriginMode: TerrainHeightOriginMode = TerrainHeightOriginMode.Geodetic): TerrainSettings | ||
clone(changedProps?: TerrainProps): TerrainSettings | Create a copy of this TerrainSettings, optionally modifying some of its properties. | |
equals(other: TerrainSettings): boolean | ||
equalsJSON(json?: BackgroundMapProps): boolean | Returns true if these settings are equivalent to the supplied JSON settings. | |
toJSON(): TerrainProps | ||
fromJSON(json?: TerrainProps): TerrainSettings Static |
Properties
Name | Type | Description | |
---|---|---|---|
applyLighting Readonly | boolean | Applying lighting can help to visualize subtle terrain variations. | |
exaggeration Readonly | number | A value greater than one will cause terrain height to be exaggerated/scaled. | |
heightOrigin Readonly | number | Origin value - height of the IModel origin at the project center as defined by heightOriginMode. | |
heightOriginMode Readonly | TerrainHeightOriginMode | Determines how/if the heightOrigin is applied to the terrain height. | |
providerName Readonly | string | Identifies the TerrainProvider that will supply terrain meshes. |
Defined in
Last Updated: 20 June, 2023