ContextRealityModel Class
A reality model not associated with a GeometricModel but instead defined in a DisplayStyle or DisplayStyleState. Such reality models are displayed to provide context to the view and can be freely attached and detached at display time.
see DisplayStyleSettings.contextRealityModels to define context reality models for a display style.
Methods
Name | Description | |
---|---|---|
constructor(props: ContextRealityModelProps): ContextRealityModel | Construct a new context reality model. | |
matchesNameAndUrl(name: string, url: string): boolean | Returns true if ContextRealityModel.name and ContextRealityModel.url match the specified name and url. | |
toJSON(): ContextRealityModelProps | Convert this model to its JSON representation. |
Properties
Name | Type | Description | |
---|---|---|---|
_appearanceOverrides Protected | undefined | FeatureAppearance | ||
_displaySettings Protected | RealityModelDisplaySettings | Beta | |
_planarClipMask Protected | undefined | PlanarClipMaskSettings | ||
appearanceOverrides Accessor | undefined | FeatureAppearance | Overrides applied to the appearance of the reality model. | |
classifiers Readonly | undefined | SpatialClassifiers | A set of SpatialClassifiers, of which one at any given time can be used to classify the reality model. | |
description Readonly | string | A description of the model suitable for display in a user interface. | |
displaySettings Accessor | RealityModelDisplaySettings | Settings controlling how this reality model is displayed in a Viewport. | |
name Readonly | string | A name suitable for display in a user interface. | |
onAppearanceOverridesChanged Readonly | BeEvent<(newOverrides: undefined | FeatureAppearance, model: ContextRealityModel) => void> | Event dispatched just before assignment to ContextRealityModel.appearanceOverrides. | |
onDisplaySettingsChanged Readonly | BeEvent<(newSettings: RealityModelDisplaySettings, model: ContextRealityModel) => void> | Event dispatched just before assignment to ContextRealityModel.displaySettings. | Beta |
onPlanarClipMaskChanged Readonly | BeEvent<(newSettings: undefined | PlanarClipMaskSettings, model: ContextRealityModel) => void> | Event dispatched just before assignment to ContextRealityModel.planarClipMaskSettings. | |
planarClipMaskSettings Accessor | undefined | PlanarClipMaskSettings | Optionally describes how the geometry of the reality model can be masked by other models. | |
rdSourceKey Readonly | undefined | RealityDataSourceKey | The reality data source key identify the reality data provider and storage format. | Beta |
realityDataId Readonly | undefined | string | An optional identifier that, if present, can be used to elide a request to the reality data service. | |
url Readonly | string | The URL that supplies the 3d tiles for displaying the reality model. |
Defined in
Last Updated: 20 June, 2023