SectionDrawingProps Interface
Properties that define a SectionDrawing.
extensions
Extends
Properties
Name | Type | Description | |
---|---|---|---|
jsonProperties | undefined | { displaySpatialView?: "true", drawingBoundaryClip?: ClipVectorProps, drawingToSpatialTransform?: TransformProps, sheetToSpatialTransform?: TransformProps } | Optional json properties of this element. | |
sectionType | undefined | SectionType | The type of section used to generate the drawing. | |
spatialView | undefined | RelatedElementProps | The spatial view from which the section was generated. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName | string | ElementProps | The full name of the ECClass for this entity, in the form "Schema:ClassName" |
code | CodeProps | ElementProps | The Code for this element |
federationGuid | undefined | string | ElementProps | A FederationGuid assigned to this element. |
id | undefined | string | ElementProps | The Id of the entity. |
isInstanceOfEntity Readonly | undefined | undefined | ElementProps | A non-existent property used to discriminate between EntityProps and Entity. |
model | string | ElementProps | The Id of the Model containing this element |
parent | undefined | RelatedElementProps | ElementProps | The Parent of this element, if defined. |
userLabel | undefined | string | ElementProps | A user-assigned label for this element. |
Defined in
- core/common/src/ElementProps.ts Line 189
Last Updated: 20 June, 2023