Placement3d Class
The placement of a GeometricElement3d. This includes the origin, orientation, and size (bounding box) of the element. All geometry of a GeometricElement are relative to its placement.
Implements
Methods
Name | Description | |
---|---|---|
constructor(origin: Point3d, angles: YawPitchRollAngles, bbox: Range3d): Placement3d | ||
calculateRange(): Range3d | Calculate the axis-aligned bounding box for this placement. | |
getWorldCorners(out?: Frustum): Frustum | Get the 8 corners, in world coordinates, of this placement. | |
multiplyTransform(other: Transform): void | Multiply the Transform of this Placement3d by the specified other Transform. | |
setFrom(other: Placement3d): void | Set the contents of this Placement3d from another Placement3d | |
fromJSON(json?: Placement3dProps): Placement3d Static | Create a new Placement3d from a Placement3dProps. |
Properties
Name | Type | Description | |
---|---|---|---|
angles | YawPitchRollAngles | ||
bbox | Range3d | ||
is3d Accessor ReadOnly | boolean | determine if this is 3d placement | |
isValid Accessor ReadOnly | boolean | Determine whether this Placement3d is valid. | |
origin | Point3d | ||
rotation Accessor ReadOnly | Matrix3d | Get the rotation from local coordinates of this placement to world coordinates. | |
transform Accessor ReadOnly | Transform | Get the transform from local coordinates of this placement to world coordinates. |
Defined in
Last Updated: 20 June, 2023