ChannelRootAspectProps Interface
Properties of an ChannelRootAspect that identifies an Element as the root of a channel which is a subset of the overall iModel hierarchy that is independently maintained.
extensions
Extends
Properties
Name | Type | Description | |
---|---|---|---|
owner | string | The owner of the channel |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName | string | ElementAspectProps | The full name of the ECClass for this entity, in the form "Schema:ClassName" |
element | RelatedElementProps | ElementAspectProps | |
id | undefined | string | ElementAspectProps | The Id of the entity. |
isInstanceOfEntity Readonly | undefined | undefined | ElementAspectProps | A non-existent property used to discriminate between EntityProps and Entity. |
jsonProperties | undefined | { T } | ElementAspectProps | Optional json properties of this Entity. |
Defined in
- core/common/src/ElementProps.ts Line 473
Last Updated: 20 June, 2023