ElementGeometryOpcode Enumeration
Specifies the type of an entry in a geometry stream.
see ElementGeometryDataEntry.opcode.
extensions
Members
Name | Value | Description |
---|---|---|
SubGraphicRange | 2 | Local range of the next geometric primitive in the geometry stream. |
PartReference | 3 | A reference to a GeometryPart. |
BasicSymbology | 4 | Sets symbology for subsequent geometry to override SubCategory appearance |
PointPrimitive | 5 | A line, line string, shape, or point string (automatic simplification of a CurvePrimitive or CurveCollection) |
PointPrimitive2d | 6 | A 2d line, line string, shape, or point string (automatic simplification of a CurvePrimitive or CurveCollection) |
ArcPrimitive | 7 | Arc or ellipse (automatic simplification of a CurvePrimitive or CurveCollection) |
CurveCollection | 8 | CurveCollection |
Polyface | 9 | Polyface |
CurvePrimitive | 10 | CurvePrimitive |
SolidPrimitive | 11 | SolidPrimitive |
BsplineSurface | 12 | BSplineSurface3d |
Fill | 19 | Opaque and ElementGeometryOpcode.Gradient fills. |
Pattern | 20 | Hatch, cross-hatch, or ElementGeometryOpcode.AreaPattern. |
Material | 21 | RenderMaterial |
TextString | 22 | TextString |
LineStyleModifiers | 23 | Specifies line style overrides as a LineStyle.Modifier |
BRep | 25 | Boundary represention solid, sheet, or wire body as a BRepEntity.DataProps |
Image | 28 | Small single-tile raster image as an ImageGraphic |
Defined in
Last Updated: 20 June, 2023