MassPropertiesPerCandidateResponseProps Interface
Information returned from the back end to the front end holding the result of the mass properties calculation for a single candidate.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
candidate | string |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
area | undefined | number | MassPropertiesResponseProps | Surface area of solids and surfaces when MassPropertiesOperation.AccumulateVolumes or MassPropertiesOperation.AccumulateAreas requested |
centroid | undefined | XYZProps | MassPropertiesResponseProps | Centroid of geometry |
ixy | undefined | number | MassPropertiesResponseProps | Product of inertia with respect to xy plane |
ixz | undefined | number | MassPropertiesResponseProps | Product of inertia with respect to xz plane |
iyz | undefined | number | MassPropertiesResponseProps | Product of inertia with respect to yz plane |
length | undefined | number | MassPropertiesResponseProps | Length of curves or perimeter of planar regions when MassPropertiesOperation.AccumulateAreas or MassPropertiesOperation.AccumulateLength requested |
moments | undefined | XYZProps | MassPropertiesResponseProps | Moments of inertia |
perimeter | undefined | number | MassPropertiesResponseProps | Perimeter of surfaces and planar regions when MassPropertiesOperation.AccumulateAreas requested |
status | BentleyStatus | MassPropertiesResponseProps | Success if requested MassPropertiesOperation could be evaluated for the specified elements |
volume | undefined | number | MassPropertiesResponseProps | Volume of solids when MassPropertiesOperation.AccumulateVolumes requested |
Defined in
Last Updated: 20 June, 2023