EcefLocation Class
The position and orientation of an iModel on the earth in ECEF (Earth Centered Earth Fixed) coordinates
note This is an immutable type - all of its properties are frozen.
Implements
Methods
Name | Description | |
---|---|---|
constructor(props: EcefLocationProps): EcefLocation | Construct a new EcefLocation. | |
getTransform(): Transform | Get the transform from iModel Spatial coordinates to ECEF from this EcefLocation | |
isAlmostEqual(other: EcefLocation): boolean | Return true if this location is equivalent to another location within a small tolerance. | |
toJSON(): EcefLocationProps | ||
createFromCartographicOrigin(origin: Cartographic, point?: Point3d, angle?: Angle): EcefLocation Static | Construct ECEF Location from cartographic origin with optional known point and angle. |
Properties
Name | Type | Description | |
---|---|---|---|
cartographicOrigin Readonly | undefined | Cartographic | Optional position on the earth used to establish the ECEF origin and orientation. | |
earthCenter Accessor ReadOnly | Point3d | Get the location center of the earth in the iModel coordinate system. | |
orientation Readonly | YawPitchRollAngles | The orientation of the ECEF transform | |
origin Readonly | Point3d | The origin of the ECEF transform. | |
xVector Readonly | undefined | Vector3d | Optional X column vector used with EcefLocation.yVector to calculate potentially non-rigid transform if a projection is present. | |
yVector Readonly | undefined | Vector3d | Optional Y column vector used with EcefLocation.xVector to calculate potentially non-rigid transform if a projection is present. |
Defined in
- core/common/src/IModel.ts Line 218
Last Updated: 20 June, 2023