HorizontalCRSProps Interface
Horizontal Geographic Coordinate Reference System definition
extensions
Implemented by
Properties
Name | Type | Description | |
---|---|---|---|
datum | undefined | GeodeticDatumProps | The complete definition of the geodetic datum referred to by datumId. | |
datumId | undefined | string | The identifier of the geodetic datum as stored in the dictionary or the service database. | |
deprecated | undefined | boolean | If true then indicates the definition is deprecated. | |
description | undefined | string | Description | |
ellipsoid | undefined | GeodeticEllipsoidProps | The complete definition of the geodetic datum referred to by datumId. | |
ellipsoidId | undefined | string | The identifier of the geodetic ellipsoid as stored in the dictionary or the service database. | |
epsg | undefined | number | The EPSG code of the CRS. | |
extent | undefined | HorizontalCRSExtentProps | Extent representing the domain of application of the CRS. | |
id | undefined | string | The identifier of the horizontal CRS as stored in the dictionary or the service database | |
name | undefined | string | Used only for user-defined definitions that will typically use a GUID as id. | |
projection | undefined | ProjectionProps | Projection including projection parameters. | |
source | undefined | string | A textual description of the source of the CRS definition. | |
unit | undefined | UnitType | The text indicating the unit used. |
Defined in
Last Updated: 20 June, 2023