ViewQueryParams Interface
Parameters for performing a query on ViewDefinition classes.
extensions
Extends
Properties
Name | Type | Description | |
---|---|---|---|
wantPrivate | undefined | boolean |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
bindings | object | any[] | EntityQueryParams | Bindings for parameterized values. |
from | undefined | string | EntityQueryParams | The sql className, in the form "Schema.ClassName", of the class to search. |
limit | undefined | number | EntityQueryParams | Optional "LIMIT" clause to limit the number of rows returned. |
offset | undefined | number | EntityQueryParams | Optional "OFFSET" clause. |
only | undefined | boolean | EntityQueryParams | Set to true to limit results to not include sub-classes of "from" class |
orderBy | undefined | string | EntityQueryParams | Optional "ORDERBY" clause to sort results. |
where | undefined | string | EntityQueryParams | Optional "WHERE" clause to filter entities. |
Defined in
- core/common/src/ViewProps.ts Line 138
Last Updated: 20 June, 2023