IpcSocketBackend Interface
Interface for the backend (Node.js) side of a socket connection. Backends provide the implementation of methods that are invoked from the frontend.
Extends
Methods
Name | Description | |
---|---|---|
handle(channel: string, handler: (...args: any[]) => Promise<any>): RemoveFunction | Establish a backend implementation of an Ipc interface for a channel. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
addListener(channel: string, listener: IpcListener): RemoveFunction | IpcSocket | Establish a handler to receive messages for a channel through a socket. |
removeListener(channel: string, listener: IpcListener): void | IpcSocket | Remove a previously registered listener |
send(channel: string, ...data: any[]): void | IpcSocket | Send a message over the socket. |
Defined in
- core/common/src/ipc/IpcSocket.ts Line 88
Last Updated: 20 June, 2023