appui-react
Classes
Name | Description | |
---|---|---|
AccuDrawCommandItems | AccuDraw Command Items - useful in Keyboard Shortcuts | Beta |
AccuDrawGrabInputFocusEvent | AccuDraw Grab Input Focus event | Beta |
AccuDrawKeyboardShortcuts | Default AccuDraw Keyboard Shortcuts | Beta |
AccuDrawSetCompassModeEvent | AccuDraw Set Compass Mode event | Beta |
AccuDrawSetFieldFocusEvent | AccuDraw Set Field Focus event | Beta |
AccuDrawSetFieldLockEvent | AccuDraw Set Field Lock event | Beta |
AccuDrawSetFieldValueFromUiEvent | AccuDraw Set Field Value from Ui event | Beta |
AccuDrawSetFieldValueToUiEvent | AccuDraw Set Field Value to Ui event | Beta |
AccuDrawUiSettingsChangedEvent | AccuDraw Ui Settings Changed event | Beta |
AccuDrawWidgetControl | AccuDraw Widget Control | Beta |
ActionButtonItemDef | Abstract base class that is used by classes to execute an action when pressed. | |
ActionItemButton | A Toolbar button React Component that executes an action defined by a CommandItemDef or a ToolItemDef. | Deprecated |
ActiveContentChangedEvent | Active Content Changed Event class. | |
ActivityCenterField | Activity Center Field React component. | |
Activity Message Cancelled Event class. | ||
Activity Message Added Event class. | ||
AnalysisAnimationTimelineDataProvider | Analysis Timeline Data Provider - Allows a TimelineComponent to animate the AnalysisStyle information stored in a ViewState. | |
AppNotificationManager | The AppNotificationManager class is a subclass of NotificationManager in @itwin/core-frontend. | |
AppUiSettings | These are the UI settings that are stored in the Redux store. | |
Backstage | Backstage React component. | Deprecated |
BackstageEvent | Backstage Event class. | Deprecated |
BackstageItemUtilities | Utilities for creating and maintaining backstage items | Beta |
BackstageManager | Controls backstage. | |
BaseUiItemsProvider | Base implementation of a UiItemsProvider. | Beta |
BooleanSyncUiListener | A component that expect its children to be a function that will be passed the current boolValue state. | |
CardPopup | Popup component for Input Editor | Beta |
ChildWindowManager | Supports opening a child browser window from the main application window. | Deprecated |
CommandItemDef | An Item that executes a Command. | |
CommandLaunchBackstageItem | Backstage item that launches a Command | Deprecated |
ConditionalField | A component that expects its children to be a function that will be passed the current component Props. | Deprecated |
ConfigurableBase | The base class for all ConfigurableUi elements | |
ConfigurableCreateInfo | Information for creating a ConfigurableUi element | |
ConfigurableUiControl | The abstract base class for all Frontstage controls. | |
ConfigurableUiManager | Configurable Ui Manager maintains controls, Frontstages, Content Groups, Content Layouts, Tasks and Workflows. | Deprecated |
ContentControl | The base class for Frontstage content controls. | |
ContentControlActivatedEvent | ContentControl Activated Event class. | |
ContentDialogChangedEvent | Content Dialog Changed Event class. | |
ContentDialogManager | Content Dialog Manager class displays and manages multiple modeless dialogs | Deprecated |
ContentDialogRenderer | ContentDialogRenderer React component renders modeless dialogs. | |
ContentGroup | ContentGroup class. | |
ContentGroupProvider | Abstract class that can be implemented and specified by frontstage to dynamically construct | |
ContentLayout | Content Layout React component. | |
ContentLayoutActivatedEvent | Content Layout Activated Event class. | |
ContentLayoutDef | Content Layout Definition class. | |
ContentLayoutManager | ContentLayout Manager class. | Deprecated |
ContentViewManager | Content View Manager class. | Deprecated |
CoreTools | Utility Class that provides definitions of tools provided by the core-frontend core. | |
CubeNavigationAidControl | Navigation Aid that displays an interactive rotation cube for Spatial views that synchronizes with the rotation of the iModel Viewport | |
CursorInformation | Cursor Information class | |
CursorPopup | CursorPopup React component | |
CursorPopupManager | CursorPopup component | |
CursorPopupRenderer | CursorPopupRenderer React component. | |
CursorUpdatedEvent | Cursor Updated Event class. | |
CustomItemDef | An Item that renders a React component. | |
DefaultNavigationWidget | Default Navigation Widget for zone 3. | Beta |
DialogChangedEvent | Dialog Changed Event class. | |
DrawingNavigationAidControl | Navigation Aid that displays an interactive mini-map for Drawing views that synchronizes with the iModel Viewport. | Beta |
ElementTooltip | ElementTooltip React component. | |
ElementTooltipChangedEvent | ElementTooltip Changed Event class. | |
ExpandableSection | Expandable Section React component used by ListPickerBase | Beta |
FloatingContentControl | Beta | |
FloatingViewportContentControl | Beta | |
FrameworkAccuDraw | Implementation of AccuDraw that sends events for UI and status changes | Beta |
FrameworkUiAdmin | The UiAdmin controls various UI components and is callable from IModelApp.uiAdmin in the core-frontend package. | |
Frontstage | Frontstage React component. | Deprecated |
FrontstageActivatedEvent | Frontstage Activated Event class. | |
FrontstageComposer | FrontstageComposer React component. | Deprecated |
FrontstageDeactivatedEvent | Frontstage Deactivated Event class. | |
FrontstageDef | FrontstageDef class provides an API for a Frontstage. | |
FrontstageLaunchBackstageItem | Backstage item that activates a Frontstage | Deprecated |
FrontstageManager | Frontstage Manager class. | Deprecated |
FrontstageProvider | Provides a definition required to create a Frontstage. | |
FrontstageReadyEvent | Frontstage Ready Event class. | |
GroupItemDef | An Item that opens a group of items. | |
HideIsolateEmphasizeActionHandler | Interface for class that handles Hide, Isolate, and Emphasize Actions | |
HideIsolateEmphasizeManager | Provides helper functions for doing commands on logical selection like categories and subjects. | |
IModelViewportControl | iModel Viewport Control | |
InputEditorCommitHandler | Beta | |
InputField message pops up near pointer when attempting an invalid interaction. | ||
Input Field Message Added Event class | ||
Input Field Message Removed Event class. | ||
ItemDefBase | The base class for Items. | |
ItemList | Contains a list of Items. | |
ItemMap | Contains a map of Items. | |
KeyboardShortcut | Keyboard Shortcut used to execute an action | |
KeyboardShortcutContainer | Keyboard Shortcut Container | |
KeyboardShortcutManager | Keyboard Shortcut Manager | Deprecated |
KeyboardShortcutMenu | React component that displays a context menu at the cursor containing keyboard shortcuts. | |
KeyboardShortcutMenuEvent | KeyboardShortcut Menu Event class. | |
KeyinBrowser | Component used to allow users to select, provide arguments, and execute a key-in. | Beta |
ListPicker | List Picker that lets the user pick from a list of items to enable/disable | Beta |
ListPickerBase | List picker base class. | Deprecated |
ListPickerItem | List Picker Item React component | Beta |
MarkupTools | Utility Class that provides definitions of tools provided by @itwin/core-markup package. | |
Message Added Event class. | ||
Message Center Field React component. | ||
The MessageManager class manages messages and prompts. | ||
Messages Updated Event class. | ||
ModalDialogChangedEvent | Modal Dialog Changed Event class. | |
ModalDialogManager | Modal Dialog Manager class displays and manages multiple modal dialogs | Deprecated |
ModalDialogRenderer | ModalDialogRenderer React component renders modal dialogs | |
ModalFrontstage | ModalFrontstage React component | |
ModalFrontstageChangedEvent | Modal Frontstage Stack Changed Event class. | |
ModalFrontstageClosedEvent | Modal Frontstage Closed Event class. | |
ModelessDialog | Modeless Dialog React component uses the Dialog component with a modal={false} prop. | |
ModelessDialogChangedEvent | Modeless Dialog Changed Event class. | |
ModelessDialogManager | Modeless Dialog Manager class displays and manages multiple modeless dialogs | Deprecated |
ModelessDialogRenderer | ModelessDialogRenderer React component renders modeless dialogs. | |
MouseDownChangedEvent | Mouse Down Changed Event class. | |
NavigationAidActivatedEvent | NavigationAid Activated Event class. | |
NavigationAidControl | The base class for Navigation Aid controls. | |
NavigationWidget | Navigation Widget React component. | Deprecated |
NavigationWidgetDef | Definition of a Navigation Widget normally displayed in the top right zone in the 9-Zone Layout system. | Deprecated |
NestedFrontstage | Nested Frontstage related classes and commands | |
Open Message Center Event class. | ||
PanelStateChangedEvent | Panel State Changed Event class. | Beta |
Pointer message pops up near pointer when attempting an invalid interaction. | ||
Pointer Message Changed Event emitted by the PointerMessage component | ||
PopupButton | Used to provide custom popup button in toolbar. | Deprecated |
PopupManager | Popup Manager class | |
PopupRenderer | Popup Renderer | |
PopupsChangedEvent | Popups Changed Event class. | |
PositionPopup | Popup component at screen position | Beta |
PropsHelper | A set of helper methods for various props | |
Describes a message to be displayed to the user and adds support for React components in messages. | ||
ReducerRegistry | Redux Reducer Registry. | Beta |
ReviewToolWidget | Default Tool Widget for standard "review" applications. | Beta |
ScheduleAnimationTimelineDataProvider | ScheduleAnimation Timeline Data Provider - allows a TimelineComponent to animate the data found in a ScheduleScript in a ViewState. | |
SelectionContextToolDefinitions | Utility Class that provides definitions for tools dependent on current selection. | |
SeparatorBackstageItem | Separator Backstage item. | Deprecated |
SettingsModalFrontstage | Modal frontstage displaying and editing settings from registered settings providers. | Beta |
StageContentLayout | StageContentLayout class. | |
StagePanel | Frontstage Panel React component. | Deprecated |
StagePanelDef | A StagePanelDef represents each Stage Panel within a Frontstage. | |
StandardContentToolsProvider | Provide standard tools for the ContentManipulationWidgetComposer. | |
StandardContentToolsUiItemsProvider | Beta | |
StandardFrontstageProvider | FrontstageProvider that provides an "empty" stage. | |
StandardMessageBox React component displays a standard icon, message text and a standard button set in the lower right. | ||
StandardNavigationToolsProvider | Provide standard tools for the ViewNavigationWidgetComposer. | |
StandardNavigationToolsUiItemsProvider | Provide standard tools for the ViewNavigationWidgetComposer. | Beta |
StandardStatusbarItemsProvider | Provide standard statusbar fields for the SimpleStatusbarWidget | |
StandardStatusbarUiItemsProvider | Provide standard statusbar fields for the SimpleStatusbarWidget | Beta |
StateManager | Centralized state management class using Redux actions, reducers and store. | |
StatusBar | Status Bar React component. | |
StatusBarItemsManager | StatusBar Items Manager class. | Beta |
StatusBarItemUtilities | Utility methods for creating and maintaining StatusBar items. | |
StatusBarWidgetComposerControl | StatusBarWidgetComposerControl provides status bar to specified Frontstage that allows status bar items to be populated | |
StatusBarWidgetControl | Status Bar Widget Control. | |
SyncToolSettingsPropertiesEvent | Sync Tool Settings Properties Event class. | |
SyncUiEventDispatcher | This class is used to send eventIds to interested UI components so the component can determine if it needs | |
TileLoadingIndicator | TileLoadingIndicator React component | |
ToolActivatedEvent | Tool Activated Event class. | |
ToolAssistanceChangedEvent | Tool Assistance Changed event class | |
ToolAssistanceField | Tool Assistance Field React component. | |
ToolbarButtonHelper | A set of Dom helper methods | |
ToolbarHelper | Helper functions for defining an ToolbarComposer. | |
ToolbarPopup | Popup component for Toolbar | Beta |
ToolbarWidgetDefBase | A Toolbar Widget normally displayed in the top left & top right zones in the 9-Zone Layout system. | Deprecated |
ToolButton | Tool Button React Component. | Deprecated |
ToolIconChangedEvent | Tool Icon Changed Event class. | |
ToolInformation | Provides information about a tool with a given id, including the ToolUiProvider. | |
ToolItemDef | An Item that starts the execution of a Tool. | |
ToolSettingsManager | Tool Settings Manager class. | Deprecated |
ToolSettingsPopup | Popup component for Tool Settings | Beta |
ToolUiProvider | ToolUiProvider provides the Tool Settings and/or Tool Assistance UI for a tool. | |
ToolWidget | ToolWidget React component. | Deprecated |
ToolWidgetDef | Definition of a Tool Widget normally displayed in the top left zone in the 9-Zone Layout system. | Deprecated |
UiFramework | Manages the Redux store, localization service and iModel, Project and Login services for the ui-framework package. | |
UiItemsManager | Controls registering of UiItemsProviders and calls the provider's methods when populating different parts of the User Interface. | Beta |
UiShowHideManager | Maintains Ui Show/Hide state. | Deprecated |
UiVisibilityChangedEvent | UiVisibility Event class. | |
UserSettingsStorage | Implementation of UserSettingsStorage.UiStateStorage that uses settings admin from IModelApp.userPreferences. | Deprecated |
ViewAttributesStatusField | Widget for showing Checkboxes for View Attributes | Beta |
ViewportContentControl | The base class for frontstage Viewport content controls that connects to a ScreenViewport |
|
ViewSelector | View Selector React component | Beta |
ViewSelectorChangedEvent | ViewSelector Changed Event class. | Beta |
ViewStateHelper | SavedView class. | |
ViewUtilities | Various View utility methods | |
Widget | Widget React component. | Deprecated |
WidgetControl | The base class for Widget controls. | |
WidgetDef | A Widget Definition in the 9-Zone Layout system. | |
WidgetHost | A WidgetHost represents a definition that hosts one or most Widgets in a Frontstage. | |
WidgetManager | Widget Manager class. | Beta |
WidgetStateChangedEvent | Widget State Changed Event class. | |
Zone | Zone React component. | Deprecated |
ZoneDef | A ZoneDef represents each zone within a Frontstage. | Deprecated |
Constants
Name | Description | |
---|---|---|
ConfigurableUiActions | An object with a function that creates each ConfigurableUiReducer that can be handled by our reducer. | |
FrameworkVersionContext | Deprecated | |
IModelConnectedNavigationWidget | DefaultNavigationWidget that is connected to the IModelConnection property in the Redux store. | Beta |
IModelConnectedViewport | Viewport that is connected to the IModelConnection property in the Redux store. | |
IModelConnectedViewSelector | ViewSelector that is connected to the IModelConnection property in the Redux store. | Beta |
PromptField | Prompt Field React component. | Deprecated |
ReducerRegistryInstance | ReducerRegistryInstance singleton instance of Reducer Registry | Beta |
SafeAreaContext | Context used to manage safe area (feature used by devices with non-rectangular screens). | |
SafeAreaInsets | Describes available safe area insets. | Beta |
SelectionInfoField | SelectionInfo Status Field React component. | |
SelectionScopeField | SelectionScopeField React component. | |
SessionStateActions | An object with a function that creates each SessionStateReducer that can be handled by our reducer. | |
sessionStateMapDispatchToProps | Object that contains available actions that modify SessionState. | Beta |
SnapModeField | Snap Mode Field React component. | |
StagePanelLocation | Available Stage Panel locations. | Beta |
StagePanelSection | Enum for Stage Panel Sections | Beta |
StageUsage | Standard stage uses. | Beta |
StatusBarLabelSide | Defines which side of Icon where label is placed | Beta |
StatusBarSection | Status bar Groups/Sections from Left to Right | Beta |
SYSTEM_PREFERRED_COLOR_THEME | System preferred color theme. | |
ThemeManager | ThemeManager handles setting color themes. | |
TOOLBAR_OPACITY_DEFAULT | The default widget opacity. | |
ToolbarDragInteractionContext | Context used to enable toolbar drag interaction. | Beta |
ToolbarOrientation | Used to specify the orientation of the toolbar. | Beta |
ToolbarUsage | Used to specify the usage of the toolbar which determine the toolbar position. | Beta |
WIDGET_OPACITY_DEFAULT | The default widget opacity. | |
WidgetState | Widget state enum. | Beta |
Enumerations
Name | Description | |
---|---|---|
BackstageItemType | Used to specify the item type added to the backstage menu. | Deprecated |
ClassGroupingOption | An option of how class grouping should work in a component. | Beta |
ColorTheme | Enum for the Color Theme string. | |
ConfigurableUiActionId | Action Ids used by Redux and to send sync UI components. | |
ConfigurableUiControlType | The type of the ConfigurableUiControl. | |
CursorDirection | Enum for Cursor Direction | |
CursorDirectionParts | Enum for Cursor Direction parts | |
HideIsolateEmphasizeAction | Supported Hide, Isolate, and Emphasize Actions. | |
KeyinFieldLocalization | Controls whether localized and/or non-localized key-in strings appear in a KeyinField's auto-completion list. | |
ListItemType | Enum for the list picker item type | Beta |
ModelsTreeNodeType | Visibility tree node types. | Beta |
SelectionScope | Selection Scope enum. | |
SessionStateActionId | Action Ids used by Redux and to send sync UI components. | |
StagePanelState | Enum for StagePanel state. | |
SyncUiEventId | Event Id used to sync UI components. | |
WidgetType | Widget type enum. | |
ZoneLocation | Enum for Zone Location. | |
ZoneState | Zone State enum. |
Global Functions
Name | Description | |
---|---|---|
AccuDrawDialog | Dialog displays AccuDrawFieldContainer for AccuDraw Ui | Beta |
AccuDrawFieldContainer | AccuDraw Ui Field Container displays AccuDrawInputField for each field | Beta |
AccuDrawInputField | Input field for AccuDraw Ui | Beta |
AccuDrawWidget | AccuDraw Widget displays AccuDrawFieldContainer for AccuDraw Ui | Beta |
Activity Message React component | Deprecated | |
Activity Message Popup React component | Deprecated | |
areNoFeatureOverridesActive | return ConditionalBooleanValue object used to show items if selection set is active. | Beta |
BackstageAppButton | BackstageAppButton used to toggle display of Backstage and is shown in the corner of the ToolWidget. | |
BackstageComposer | Backstage component composed from BackstageManager items. | |
BasicNavigationWidget | Basic Navigation Widget that provides standard tools to manipulate views containing element data. | |
BasicToolWidget | Default Tool Widget for standard "review" applications. | |
Card | Card component | Beta |
CategoryTree | Tree which displays and manages categories contained in an iModel. | Deprecated |
ClearEmphasisStatusField | Clear Emphasis StatusField | Beta |
combineReducers | Turns an object whose values are different reducer functions, into a single | |
ConfigurableUiContent | The ConfigurableUiContent component is the component the pages specified using ConfigurableUi | |
ConfigurableUiReducer | Handles actions to update ConfigurableUiState. | |
connectIModelConnection | Function that will connect a component to the IModelConnection data in the Redux store. | |
connectIModelConnectionAndViewState | Function that will connect a component to the IModelConnection data in the Redux store | Beta |
ContentDialog | Content Dialog React component uses the Dialog component with a modal={false} prop. | |
ContentToolWidgetComposer | ContentToolWidgetComposer composes a Tool Widget with no tools defined by default. | |
createAction | Creates a basic Redux Redux Action with a payload value. | |
CursorPopupContent | CursorPopup content with padding | |
DefaultDialogGridContainer | DefaultDialogGridContainer populates a React node with the items specified by the UiLayoutDataProvider | |
DefaultViewOverlay | Default viewport overlay that examines ViewState of the active view for a schedule script, analysis data, or solar data. | |
featureOverridesActiveStateFunc | return state with isVisible set to true is SectionSet is active. | Beta |
FloatingViewportContent | FloatingViewportContent component that creates its own [FloatingViewportContentControl]. | Beta |
FooterModeField | A component that renders its children if the StatusBar is in Footer mode. | Deprecated |
FrameworkReducer | Framework reducer that combines the ConfigurableUiReducer and SessionStateReducer. | |
FrameworkVersion | The FrameworkVersion component provides uiVersion context to react component. | Deprecated |
getBackstageItemStateFromProps | Helper method to set backstage item state from props. | Deprecated |
getFeatureOverrideSyncEventIds | return SyncEventIds that trigger selection state function refresh. | Beta |
getIsHiddenIfFeatureOverridesActive | return ConditionalBooleanValue object used to show item if feature overrides are active. | Beta |
getIsHiddenIfSelectionNotActive | return ConditionalBooleanValue object used to show items if selection set is active. | Beta |
getListPanel | Beta | |
getQuantityFormatsSettingsManagerEntry | Return a SettingsTabEntry that can be used to define the available settings that can be set for an application. | Beta |
getSelectionContextSyncEventIds | return SyncEventIds that trigger selection state function refresh. | Beta |
getUiSettingsManagerEntry | Beta | |
GroupButton | Group Button React component | Deprecated |
Indicator | General-purpose Footer indicator. | Deprecated |
isBackstageActionItem | BackstageActionItem type guard. | Beta |
isBackstageStageLauncher | BackstageStageLauncher type guard. | Beta |
isNoSelectionActive | return SyncEventIds that trigger selection state function refresh. | Beta |
isStatusBarActionItem | StatusBarActionItem type guard. | Beta |
isStatusBarCustomItem | StatusBarCustomItem type guard. | Beta |
isStatusBarItem | StatusBarItem type guard. | Deprecated |
isStatusBarLabelItem | StatusBarLabelItem type guard. | Beta |
isToolbarActionItem | ToolbarActionItem type guard. | Beta |
isToolbarCustomItem | ToolbarCustomItem type guard. | Beta |
isToolbarGroupItem | ToolbarGroupItem type guard. | Beta |
KeyinPalettePopup | Keyin Palette Popup Component | |
ModelsTree | A tree component that shows a subject - model - category - element | Deprecated |
NavigationAidHost | NavigationAidHost is a component that hosts a NavigationAid that is specific to the active content control. | |
NavigationWidgetComposer | Component that Composes a NavigationWidget typically using toolbars generated via ToolbarComposer class. | |
PositionPopupContent | PositionPopup content with padding | Beta |
QuantityFormatSettingsPage | UI Component shown in settings page to set the active Presentation Unit System and to set format overrides. | Beta |
SectionsStatusField | Status Field for showing section extra tools for clearing and showing manipulators | Beta |
selectionContextStateFunc | return state with isVisible set to true is SectionSet is active. | Beta |
SessionStateReducer | Handles actions to update SessionState. | |
SpatialContainmentTree | Tree which displays and manages models or categories contained in an iModel. | Deprecated |
SplitPane | Local TypeScript implementation of SplitPane from react-split-pane package since that |
|
StatusBarCenterSection | StatusBar Center Section React functional component | |
StatusBarComposer | Component to load components into the StatusBar. | |
StatusBarDialog | Dialog component used in a StatusBarIndicator component. | Beta |
StatusBarDialogTitleBar | Dialog component used in a StatusBarDialog component. | Beta |
StatusBarDialogTitleBarButton | Dialog component used in a StatusBarDialog component. | Beta |
StatusBarIndicator | General-purpose StatusBar indicator. | Beta |
StatusBarLabelIndicator | StatusBar indicator that shows a label with an icon. | Beta |
StatusBarLeftSection | StatusBar Left Section React functional component | |
StatusBarRightSection | StatusBar Right Section React functional component | |
StatusBarSeparator | Component used to separate status fields in a status bar. | |
StatusBarSpaceBetween | StatusBar With Space Between Items React functional component | |
Message Popup React component that renders one or more Toast or Sticky messages and an Activity message without a StatusBar. | Deprecated | |
Sticky Message React component | Deprecated | |
Toast Message React component | Deprecated | |
ToolbarComposer | Toolbar that is populated and maintained by item managers. | |
ToolSettingsGridContainer | Component to provide grid of property editors | |
ToolWidgetComposer | ToolWidget component that supports use of ToolbarComposer-based Toolbars. | |
UiDataProvidedDialog | Component to show dialog populated from properties supplied via uiDataProvider | |
UiSettingsPage | Beta | |
UiStateStorageHandler | Allows to provide a custom UiStateStorageHandler.UiStateStorage implementation to persist UI settings. | |
useActiveFrontstageId | Hook that returns active frontstage id. | |
useActiveIModelConnection | React hook that maintains the active IModelConnection. | |
useActiveStageId | React hook that maintains the active stage Id. | |
useActiveViewport | React hook that maintains the active viewport. | |
useAnalysisAnimationDataProvider | Hook that returns either a AnalysisAnimationTimelineDataProvider or undefined based on if the supplied viewport contains analysis data. | |
useBackstageManager | Hook that returns backstage manager. | |
useDefaultStatusBarItems | Hook that returns items from StatusBarItemsManager. | |
useDefaultToolbarItems | Hook that returns items from ToolbarItemsManager. | |
useFrameworkVersion | Deprecated | |
useIsBackstageOpen | Hook that returns isOpen flag of the backstage. | |
useScheduleAnimationDataProvider | Hook that returns either a ScheduleAnimationTimelineDataProvider or undefined based on if the supplied viewport contains schedule script. | |
useSolarDataProvider | Hook that returns either a SolarTimelineDataProvider or undefined based on if the supplied viewport's display style is set to display shadows. | Beta |
useSpecificWidgetDef | Hook that returns the widgetDef for a specific widgetId within the active frontstage. | |
useTransientState | Hook that allows to save and restore transient DOM state (i.e. | Beta |
useUiItemsProviderBackstageItems | Hook that returns items from BackstageItemsManager. | |
useUiItemsProviderStatusBarItems | Hook that returns items from StatusBarItemsManager. | |
useUiItemsProviderToolbarItems | Hook that returns items from ToolbarItemsManager. | |
useUiStateStorageHandler | ||
ViewToolWidgetComposer | ViewToolWidgetComposer composes a Navigation Widget with no tools defined by default. | |
HOC that injects values for MessageCenterFieldProps. | ||
withSafeArea | HOC that injects SafeAreaInsets. | Deprecated |
withStatusFieldProps | HOC that injects values for StatusFieldProps. | Deprecated |
Interfaces
Name | Description | |
---|---|---|
AccuDrawDialogProps | Properties for AccuDrawDialog | Beta |
AccuDrawFieldContainerProps | Properties for AccuDrawFieldContainer component | Beta |
AccuDrawInputFieldProps | Properties for AccuDrawInputField component | Beta |
AccuDrawSetCompassModeEventArgs | Arguments for AccuDrawSetCompassModeEvent | Beta |
AccuDrawSetFieldFocusEventArgs | Arguments for AccuDrawSetFieldFocusEvent | Beta |
AccuDrawSetFieldLockEventArgs | Arguments for AccuDrawSetFieldLockEvent | Beta |
AccuDrawSetFieldValueFromUiEventArgs | Arguments for AccuDrawSetFieldValueFromUiEvent | Beta |
AccuDrawSetFieldValueToUiEventArgs | Arguments for AccuDrawSetFieldValueToUiEvent | Beta |
AccuDrawUiSettings | AccuDraw User Interface Settings | Beta |
Action | A basic Redux Action. | |
ActionItemButtonProps | Properties that must be specified for an ActionItemButton component | Deprecated |
ActionWithPayload | A Redux Action, with additional "payload" information. | |
ActiveContentChangedEventArgs | ActiveContentChangedEvent Args interface. | |
Activity Message Event arguments. | ||
Properties for ActivityMessagePopup component | Deprecated | |
Properties for a ActivityMessage | Deprecated | |
BackstageActionItem | Describes the data needed to insert an action button into the backstage menu. | Beta |
BackstageAppButtonProps | Properties for the BackstageAppButton React component | |
BackstageComposerProps | Props of BackstageComposer component. | |
BackstageEventArgs | BackstageEvent arguments. | Deprecated |
BackstageItemProps | Base properties for a Backstage item. | Deprecated |
BackstageItemState | Properties that define the state of a Backstage items. | Deprecated |
BackstageProps | Properties for the Backstage React component. | Deprecated |
BackstageStageLauncher | Describes the data needed to insert an action button into the backstage menu. | Beta |
BackstageToggledArgs | Arguments of Backstage.onToggled. | |
BaseItemState | Base state for any 'stateful' React component | |
BasicNavigationWidgetProps | Properties that can be used to append items to the default set of toolbar items of DefaultNavigationWidget. | |
BasicToolWidgetProps | Properties that can be used to append items to the default set of toolbar items of ReviewToolWidget. | |
BooleanListenerProps | Properties supported by BooleanSyncUiListener component. | |
CardPopupProps | Props for defining a CardPopup editor | Beta |
CardProps | Props defining a Card component | Beta |
CategoryTreeProps | Properties for the CategoryTree component | Deprecated |
ChildWindowLocationProps | ||
CommandItemProps | Properties for a Command item. | |
CommandLaunchBackstageItemProps | Properties for a CommandLaunchBackstageItem component | Deprecated |
CommonWidgetProps | Properties of a Widget. | Beta |
ConditionalFieldProps | Properties supported by ConditionalField component. | |
ConfigurableUiContentProps | Properties for ConfigurableUiContent | |
ConfigurableUiElement | Interface for a ConfigurableUi element | |
ConfigurableUiState | The portion of state managed by the ConfigurableUiReducer. | |
ContentControlActivatedEventArgs | ControlControl Activated Event Args interface. | |
ContentDialogInfo | ||
ContentDialogProps | Properties for the ContentDialog component | |
ContentGroupProps | Properties for a ContentGroup | |
ContentLayoutActivatedEventArgs | Content Layout Activated Event Args class. | |
ContentLayoutComponentProps | Properties for the ContentLayout React component. | |
ContentProps | Properties for content displayed in a content view | |
ContentToolWidgetComposerProps | Props for ContentToolWidgetComposer. | |
CursorMenuData | Definition of data added to Redux store to define cursor menu. | |
CursorPopupOptions | Options for the CursorPopupManager open method | |
CursorPopupProps | Properties for the CursorPopup React component | |
CursorUpdatedEventArgs | Cursor Updated Event Args interface. | |
CustomItemProps | Definition for a Custom item that renders a React component. | |
DeepReadonlyArray | TypeScript doesn't actually allow recursive type aliases, so these are just sort of a hack to make DeepReadonly work | |
DefaultContentTools | Defines what tools to include from the provider. | |
DefaultContentToolsAppData | Defines options that may be set in frontstage app data to control what group priorities | |
DefaultNavigationProps | Properties that can be used to append items to the default set of toolbar items of DefaultNavigationWidget. | Beta |
DefaultNavigationTools | Defines what tools to include from the provider. | |
DefaultStatusbarItems | Defines what items to include from the provider. | |
DialogChangedEventArgs | Dialog Stack Changed Event Args class. | |
DialogInfo | Information maintained by a Dialog Manager about a dialog | |
ElementTooltipChangedEventArgs | ElementTooltipChangedEvent arguments. | |
EmphasizeElementsChangedArgs | Selection Context Action Event Argument | |
ExpandableSectionProps | Properties for the ExpandableSection component | Beta |
ExtensibleToolbarProps | Properties for the ToolbarComposer React components | |
FloatingViewportContentProps | Beta | |
FooterModeFieldProps | Properties for a FooterModeField component | |
FrameworkBackstage | UiFramework.backstage interface. | |
FrameworkChildWindows | UiFramework.childWindows interface. | Beta |
FrameworkContent | UiFramework.content interface | Beta |
FrameworkControls | UiFramework.controls interface | Beta |
FrameworkDialog | Manages dialog access | Beta |
FrameworkDialogs | UiFramework.dialogs interface. | Beta |
FrameworkFrontstages | UiFramework.frontstages interface | Beta |
FrameworkKeyboardShortcut | Keyboard Shortcut used to execute an action | |
FrameworkKeyboardShortcutContainer | Keyboard Shortcut Container | |
FrameworkKeyboardShortcuts | UiFramework.keyboardShortcuts interface | Beta |
FrameworkRootState | Generic 'root' state for the appui-react package. | Beta |
FrameworkStackedDialog | FrameworkDialog that manages the top most content. | Beta |
FrameworkState | Interface combining all the Framework state interfaces. | |
FrameworkToolSettings | UiFramework.toolSettings interface | Beta |
FrameworkVersionProps | Deprecated | |
FrameworkVisibility | UiFramework.visibility interface | Beta |
FrontstageActivatedEventArgs | Frontstage Activated Event Args interface. | |
FrontstageConfig | Configuration from which a frontstage is created. | Beta |
FrontstageDeactivatedEventArgs | Frontstage Deactivated Event Args interface. | |
FrontstageLaunchBackstageItemProps | Properties for a FrontstageLaunchBackstageItem component | Deprecated |
FrontstageProps | Properties for a Frontstage component. | Deprecated |
FrontstageReadyEventArgs | Frontstage Ready Event Args interface. | |
GroupButtonProps | Properties for the GroupButton React component | Deprecated |
GroupItemProps | Definition for a Group item that opens a group of items. | |
IModelViewportControlOptions | IModelViewportControl options. | |
InitialAppUiSettings | Default values that may be specified for AppUiSettings. | |
InputEditorPopupProps | Props for popup editor | Beta |
Input Field Message Event arguments. | ||
ItemProps | Definition that specifies properties shared between many ConfigurableUi components. | |
KeyboardShortcutMenuState | State for a KeyboardShortcutMenuEvent and KeyboardShortcutMenu component | |
KeyboardShortcutProps | Properties for a Keyboard Shortcut | |
KeyinBrowserExecuteArgs | Arguments for KeyinBrowserProps onExecute callback. | Beta |
KeyinBrowserProps | Properties of the KeyinBrowser component. | Beta |
KeyinEntry | Defines a keyin entry to show/filter in UI | |
KeyinPalettePopupProps | Props defining KeyinPalettePopup component | |
ListItem | List picker item | Beta |
ListPickerItemProps | Properties for the ListPickerItem component | Beta |
ListPickerProps | Properties for the ListPickerBase component | Beta |
ListPickerPropsExtended | Properties for the ListPicker component | Beta |
MessageAddedEvent arguments. | ||
Properties for withMessageCenterFieldProps HOC. | ||
ModalFrontstageChangedEventArgs | Modal Frontstage Changed Event Args interface. | |
ModalFrontstageClosedEventArgs | Modal Frontstage Closed Event Args interface. | |
ModalFrontstageInfo | Modal Frontstage information interface. | |
ModalFrontstageProps | Properties for the ModalFrontstage React component | |
ModelessDialogInfo | ||
ModelessDialogProps | Properties for the ModelessDialog component | |
ModelsTreeProps | Props for ModelsTree component | Deprecated |
MouseDownChangedEventArgs | MouseDownChangedEvent Args interface. | |
NameToReducerMap | NameToReducerMap used by Reducer Registry | |
NavigationAidActivatedEventArgs | NavigationAid Activated Event Args interface. | |
NavigationAidHostProps | Properties for the NavigationAidHost React component | |
NavigationWidgetComposerProps | Properties for the NavigationWidgetComposer React components | |
NavigationWidgetProps | Properties for a Navigation Widget. | Deprecated |
NavigationWidgetPropsEx | Properties for the NavigationWidget React component. | Deprecated |
NineZoneChangeHandler | Interface defining callbacks for nine zone changes | Deprecated |
OpenChildWindowInfo | ||
PanelStateChangedEventArgs | Panel State Changed Event Args interface. | |
PointerMessageChangedEvent arguments. | ||
Properties of PointerMessage component. | ||
PopupButtonChildrenRenderPropArgs | Arguments of PopupButtonChildrenRenderProp. | Deprecated |
PopupButtonProps | Properties for the PopupButton React component | Deprecated |
PopupInfo | Information maintained by PopupManager about a Popup | |
PopupPropsBase | Props for each popup managed by the PopupManager | |
PopupsChangedEventArgs | ||
PositionPopupProps | Props for popup at screen position | Beta |
PresentationSelectionScope | PresentationSelectionScope holds the id and the localized label for a selection scope supported for a specific iModel. | |
QuantityFormatterSettingsOptions | Options to initialize the settings page that allows users to set Quantity formatting overrides. | Beta |
ReactContent | Describes React based content | |
ReviewToolWidgetProps | Properties that can be used to append items to the default set of toolbar items of ReviewToolWidget. | Beta |
SectionsStatusFieldProps | Sections Status Field Props | Beta |
SessionState | The portion of state managed by the SessionStateReducer. | |
SessionStateActionsProps | An interface that allows redux connected object to dispatch changes to the SessionState reducer. | Beta |
SpatialContainmentTreeProps | Properties for the SpatialContainmentTree component | Deprecated |
SplitPaneProps | Props for SplitPane component | |
StageContentLayoutProps | StageContentLayoutProps interface for sharing view layout information. | |
StagePanelChangeHandler | Interface defining callbacks for stage panel changes | Deprecated |
StagePanelConfig | Configuration from which a stage panel is created. | Beta |
StagePanelProps | Properties of a StagePanel component | Deprecated |
StagePanelSectionsConfig | Configuration from which stage panel sections are created. | Beta |
StagePanelZoneProps | Properties of a Stage Panel Zone | |
StagePanelZonesProps | Properties of the Stage Panel Zones | |
StandardFrontstageProps | Props for StandardFrontstageProvider | |
Properties for StandardMessageBox React component | ||
StatusBarComposerProps | Properties for the StatusBarComposer React components | |
StatusBarDialogProps | Properties of StatusBarDialog component. | Beta |
StatusBarDialogTitleBarButtonProps | Properties of StatusBarDialogTitleBarButton component. | Beta |
StatusBarDialogTitleBarProps | Properties of StatusBarDialogTitleBar component. | Beta |
StatusBarIndicatorProps | Properties of StatusBarIndicator component. | Beta |
StatusBarItem | Describes the data needed to insert an item into the StatusBar. | Deprecated |
StatusBarLabelIndicatorProps | Properties of StatusBarLabelIndicator component. | Beta |
StatusBarProps | Properties for the StatusBar React component | |
StatusBarWidgetControlArgs | Status Bar Widget Control render prop arguments. | |
StatusFieldProps | Properties for a StatusBar field component | |
Properties for StatusMessageRenderer component | Deprecated | |
Properties for a StickyMessage | Deprecated | |
SupportsViewSelectorChange | Interface to be implemented when the ContentControl supports ViewSelector changes | |
SyncToolSettingsPropertiesEventArgs | Sync Tool Settings Properties Event Args interface. | |
TargetChangeHandler | Interface defining callbacks for ZoneDropTarget changes | Deprecated |
Properties for a ToastMessage | Deprecated | |
ToolActivatedEventArgs | Tool Activated Event Args interface. | |
ToolAssistanceChangedEventArgs | Tool Assistance Changed event arguments. | |
ToolAssistanceFieldProps | Properties of ToolAssistanceField component. | |
ToolbarPopupProps | Props for a popup toolbar | Beta |
ToolbarWidgetProps | Properties for a Toolbar Widget. | Deprecated |
ToolButtonProps | Properties for the ToolButton React Component. | Deprecated |
ToolIconChangedEventArgs | Tool Icon Changed Event Args interface. | |
ToolItemProps | Properties for a Tool item with a tool id. | |
ToolSettingsEntry | Defines a ToolSettings property entry. | |
ToolSettingsPopupProps | Props for defining a popup tool settings component | Beta |
ToolWidgetComposerProps | Properties for the ToolbarComposer React components | |
ToolWidgetProps | Properties for a Tool Widget. | Deprecated |
ToolWidgetPropsEx | Properties for the ToolWidget React component. | Deprecated |
UiDataProvidedDialogProps | Props for UiDataProvidedDialog component. | |
UiSettingsProviderProps | Properties for the UiStateStorageHandler component. | |
UiVisibilityEventArgs | UiVisibility Event Args interface. | |
UnitSystemSelectorProps | Props for UnitSystemSelector | Beta |
UserSettingsProvider | Interface to be implemented but any classes that wants to load their user settings when the UiStateEntry storage class is set. | |
ViewLayout | ViewLayout interface for sharing view layout information. | |
ViewOverlayProps | Props of Viewport Overlay Control that show timelines | |
ViewSelectorChangedEventArgs | ViewSelectorChangedEvent Args interface. | Beta |
ViewSelectorProps | Properties for the ViewSelector component | Beta |
ViewStateHelperProps | SavedViewProps interface for sharing ViewState and EmphasizeElements information. | |
ViewToolWidgetComposerProps | Props for ViewToolWidgetComposer. | |
WidgetChangeHandler | Interface defining callbacks for widget changes | Deprecated |
WidgetProps | Properties for a Widget component. | Deprecated |
WidgetStateChangedEventArgs | Widget State Changed Event Args interface. | |
ZoneDefProvider | Interface defining a provider for Zone definitions | Deprecated |
ZoneProps | Properties of a Zone component | Deprecated |
Namespaces
Name | Description | |
---|---|---|
StatusBarDialog | Components used in a StatusBarDialog. | Beta |
StatusBarItemUtilities | Helper class to create Abstract StatusBar Item definitions. | |
ToolbarItemUtilities | Helper class to create StatusBar Item definitions. | Beta |
Type Aliases
Name | Description | |
---|---|---|
ActionCreatorsObject | Just an object where every property is a Redux Action Creator. | |
ActionsUnion | A TypeScript type alias that represents the Union Type of all actions | |
ActionTypes | A TypeScript type alias that uses conditional types (read: magic) | |
AllowedUiItemsProviderOverrides | UiItemsProvider overrides allows the application that registers a provider to limit when it is allowed to provide items | Beta |
AnyItemDef | Union of all Item definitions that can be specified in a GroupItem | |
AnyStatusBarItem | Describes the data needed to insert a button into the status bar. | Beta |
AnyToolbarItemDef | Union of all Item definitions that can be specified in a Toolbar | |
AnyWidgetProps | Union of all Widget properties. | Deprecated |
BackstageItem | Describes the data needed to insert a button into the backstage menu. | Beta |
CombinedReducerState | A type alias which represents the state created by the reducer returned by combineReducers for a given reducers argument. |
|
CombineReducersFunction | ||
CommonBackstageItem | Describes the data needed to insert a button into the backstage menu. | Beta |
CommonStatusBarItem | Describes the data needed to insert a button into the status bar. | Beta |
CommonToolbarItem | Describes the data needed to insert a UI items into an existing set of UI items. | Beta |
ConfigurableUiActionsUnion | Union of ConfigurableUi Redux actions | |
ConfigurableUiControlConstructor | ||
ContentCallback | ||
DeepReadonly | Similar to the built-in Readonly, type alias but applied recursively. | |
DeepReadonlyObject | TypeScript doesn't actually allow recursive type aliases, so these are just sort of a hack to make DeepReadonly work | |
FrameworkVersionId | Defined that available UI Versions. | Deprecated |
FunctionType | ||
MenuItemProps | Menu Item Properties | |
ModelsTreeSelectionPredicate | ||
Types for NotifyMessageDetails. | ||
Types for message in MessageManager | ||
PopupButtonChildrenRenderProp | ||
PopupContentType | Type for Popup Content | |
ProviderItem | Properties for an item provided by UiItemsProvider. | Beta |
Reducer | ||
ReducerActions | A TypeScript type alias that represents a union of all action types handled by a Redux Reducer. | |
ReducerMapActions | A type alias which represents the union type of all actions handled by the reducer returned by combineReducers for a given reducers argument. |
|
SafeAreaInsets | Describes available safe area insets. | Beta |
SessionStateActionsUnion | Union of SessionState Redux actions | |
StagePanelDefaultProps | Default properties of StagePanel component. | Deprecated |
StagePanelLocation | Available Stage Panel locations. | Beta |
StagePanelMaxSizeSpec | Available units of panel maximum size. | |
StagePanelSection | Enum for Stage Panel Sections | Beta |
StagePanelSectionConfig | Configuration from which a stage panel section is created. | Beta |
StageUsage | Standard stage uses. | Beta |
StateType | A TypeScript type alias that represents the return type of a Redux Reducer. | |
StatusBarActionItem | Describes the data needed to insert an action item into the status bar. | Beta |
StatusBarCustomItem | Describes the data needed to insert an item into the StatusBar. | Beta |
StatusBarFieldId | Status Bar Field type. | |
StatusBarLabelItem | Describes the data needed to insert a label item with an optional icon into the status bar. | Beta |
StatusBarLabelSide | Defines which side of Icon where label is placed | Beta |
StatusBarSection | Status bar Groups/Sections from Left to Right | Beta |
SyncUiEvent | SyncUi Event class. | |
SyncUiEventArgs | SyncUi Event arguments. | |
ToolbarActionItem | Describes the data needed to insert an action button into a toolbar. | Beta |
ToolbarCustomItem | Describes the data needed to insert a custom button into a toolbar. | Beta |
ToolbarGroupItem | Describes the data needed to insert a group button into a toolbar. | Beta |
ToolbarItem | Any Button Type that can be inserted into a toolbar. | Beta |
ToolbarOrientation | Used to specify the orientation of the toolbar. | Beta |
ToolbarUsage | Used to specify the usage of the toolbar which determine the toolbar position. | Beta |
UiItemsProvider | Describes interface of objects that want to provide UI component to the running IModelApp. | Beta |
UiItemsProviderOverrides | Allowed overrides applied to a UiItemsProvider the application that registers a provider to limit when it is allowed to provide items. | Beta |
UiItemsProviderRegisteredEventArgs | UiItemsProvider register event args. | Beta |
ViewSelectorDefaultProps | Default properties of ViewSelector component. | Beta |
WidgetConfig | Configuration from which a widget is created. | Beta |
WidgetPanelProps | Properties of a WidgetPanelProps component | |
WidgetState | Widget state enum. | Beta |
WidgetStateFunc |
Last Updated: 20 June, 2023