AppUiSettings Class
These are the UI settings that are stored in the Redux store. They control the color theme, the UI version, how toolbar group buttons work, and the opacity of widgets in 1.0 and floating widget in 2.0 when the cursor is not inside them. It is expect that an IModelApp using App UI components will create and register AppUiSettings with defaults specific to their application. This would be done by calling the following.
UiFramework.registerUserSettingsProvider(new AppUiSettings(defaults));
Implements
Methods
Name | Description | |
---|---|---|
constructor(defaults: Partial<InitialAppUiSettings>): AppUiSettings | ||
apply(storage: UiStateStorage): Promise<void> | ||
loadUserSettings(storage: UiStateStorage): Promise<void> | Function to load settings from settings storage |
Properties
Name | Type | Description | |
---|---|---|---|
animateToolSettings | UiStateEntry<boolean> | ||
autoCollapseUnpinnedPanels | UiStateEntry<boolean> | ||
colorTheme | UiStateEntry<string> | ||
dragInteraction | UiStateEntry<boolean> | ||
frameworkVersion | UiStateEntry<FrameworkVersionId> | Deprecated | |
providerId Readonly | "AppUiSettingsProvider" | Unique provider Id | |
showWidgetIcon | UiStateEntry<boolean> | ||
toolbarOpacity | UiStateEntry<number> | ||
useToolAsToolSettingsLabel | UiStateEntry<boolean> | ||
widgetOpacity | UiStateEntry<number> |
Defined in
Last Updated: 20 June, 2023