KeyboardShortcutContainer Class
Keyboard Shortcut Container
Methods
Name | Description | |
---|---|---|
constructor(): KeyboardShortcutContainer | ||
areKeyboardShortcutsAvailable(): boolean | Determines if any Keyboard Shortcuts are available in this container | |
emptyData(): void | Empties any Keyboard Shortcuts from this container | |
findKey(keyMapKey: string): undefined | KeyboardShortcut | Finds a Keyboard Shortcut associated with a given key | |
getAvailableKeyboardShortcuts(): KeyboardShortcut[] | ||
registerKey(keyMapKey: string, inShortcut: KeyboardShortcut): undefined | KeyboardShortcut | Registers a Keyboard Shortcut associated with a given key in the managed list | |
showShortcutsMenu(): void | Displays a menu for the Keyboard Shortcuts in this container | |
generateKeyMapKey(keyboardKey: string, isAltKeyRequired: boolean, isCtrlKeyRequired: boolean, isShiftKeyRequired: boolean): string Static | Generates a key used for storing and finding the Keyboard Shortcuts in this container |
Defined in
Last Updated: 20 June, 2023