UiFramework Class
Manages the Redux store, localization service and iModel, Project and Login services for the ui-framework package.
Methods
Name | Description | |
---|---|---|
constructor(): UiFramework | ||
closeCursorMenu(): void Static | ||
dispatchActionToStore(type: string, payload: any, immediateSync: boolean = false): void Static | ||
getAccudrawSnapMode(): SnapMode Static | ||
getActiveIModelId(): string Static | ||
getActiveSelectionScope(): string Static | ||
getAvailableSelectionScopes(): PresentationSelectionScope[] Static | ||
getColorTheme(): string Static | ||
getCursorMenuData(): undefined | CursorMenuData Static | ||
getDefaultIModelViewportControlId(): undefined | string Static | ||
getDefaultViewId(): undefined | string Static | ||
getDefaultViewState(): undefined | ViewState Static | ||
getIModelConnection(): undefined | IModelConnection Static | ||
getIsUiVisible(): boolean Static | ||
getToolbarOpacity(): number Static | UiFramework.getToolbarOpacity() returns a number between 0 and 1 that is the non-hovered opacity for toolbars. | |
getUiStateStorage(): UiStateStorage Static | The UI Settings Storage is a convenient wrapper around Local Storage to assist in caching state information across user sessions. | |
getWidgetOpacity(): number Static | ||
initialize(store: undefined | Store<any, AnyAction>, frameworkStateKey?: string): Promise<void> Static | Called by the application to initialize the UiFramework. | |
initialize(store: undefined | Store<any, AnyAction>, frameworkStateKey?: string, startInUi1Mode?: boolean): Promise<void> Static | Called by the application to initialize the UiFramework. | Deprecated |
initializeStateFromUserSettingsProviders(immediateSync: boolean = false): Promise<void> Static | Called by iModelApp to initialize saved UI state from registered UseSettingsProviders | |
isMobile(): boolean Static | ||
openCursorMenu(menuData: undefined | CursorMenuData): void Static | ||
registerUserSettingsProvider(entry: UserSettingsProvider): boolean Static | Registers class that will be informed when the UserSettingsStorage location has been set or changed. | Beta |
setAccudrawSnapMode(snapMode: SnapMode): void Static | ||
setActiveIModelId(iModelId: string): void Static | ||
setActiveSelectionScope(selectionScopeId: string): void Static | ||
setAnimateToolSettings(value: boolean): void Static | ||
setColorTheme(theme: string): void Static | ||
setDefaultIModelViewportControlId(iModelViewportControlId: string, immediateSync: boolean = false): void Static | ||
setDefaultViewId(viewId: string, immediateSync: boolean = false): void Static | ||
setDefaultViewState(viewState: ViewState, immediateSync: boolean = false): void Static | ||
setIModelConnection(iModelConnection: undefined | IModelConnection, immediateSync: boolean = false): void Static | ||
setIsUiVisible(visible: boolean): void Static | ||
setShowWidgetIcon(value: boolean): void Static | ||
setToolbarOpacity(opacity: number): void Static | UiFramework.setToolbarOpacity() sets the non-hovered opacity to the value specified. | |
setUiStateStorage(storage: UiStateStorage, immediateSync: boolean = false): Promise<void> Static | ||
setUiVersion(version: FrameworkVersionId): void Static | Deprecated | |
setUseDragInteraction(useDragInteraction: boolean): void Static | ||
setUseToolAsToolSettingsLabel(value: boolean): void Static | ||
setViewOverlayDisplay(display: boolean): void Static | Set the variable that controls display of the view overlay. | |
setWidgetOpacity(opacity: number): void Static | ||
terminate(): void Static | Un-registers the UiFramework internationalization service namespace |
Properties
Name | Type | Description | |
---|---|---|---|
animateToolSettings Accessor StaticReadOnly | boolean | Animate Tool Settings on appear | |
backstage Accessor StaticReadOnly | FrameworkBackstage | Operation on the backstage component. | |
backstageManager Accessor StaticReadOnly | BackstageManager | ||
childWindowManager Accessor StaticReadOnly | ChildWindowManager | ||
childWindows Accessor StaticReadOnly | FrameworkChildWindows | Manage access to the child windows. | |
content Accessor StaticReadOnly | FrameworkContent | Manage content presented by the frontstages. | |
controls Accessor StaticReadOnly | FrameworkControls | Manage registered controls | |
dialogs Accessor StaticReadOnly | FrameworkDialogs | Manage displayed dialogs. | |
frameworkState Accessor StaticReadOnly | undefined | FrameworkState | The UiFramework state maintained by Redux | |
frameworkStateKey Accessor StaticReadOnly | string | ||
frontstages Accessor StaticReadOnly | FrameworkFrontstages | Manage access to frontstages and related helper methods. | |
initialized Accessor StaticReadOnly | boolean | Determines if UiFramework has been initialized | |
keyboardShortcuts Accessor StaticReadOnly | FrameworkKeyboardShortcuts | Manages global keyboard shortcuts | |
localizationNamespace Accessor StaticReadOnly | string | The internationalization service namespace. | |
onUiVisibilityChanged StaticReadonly | UiVisibilityChangedEvent | Get Show Ui event. | |
settingsManager Accessor StaticReadOnly | SettingsManager | Property that returns the SettingManager used by AppUI-based applications. | |
showWidgetIcon Accessor StaticReadOnly | boolean | ||
store Accessor StaticReadOnly | Store<any, AnyAction> | The Redux store | |
toolSettings Accessor StaticReadOnly | FrameworkToolSettings | Manage access and behavior of the tool settings. | |
uiVersion Accessor StaticReadOnly | FrameworkVersionId | Returns the Ui Version. | |
useDefaultPopoutUrl Static | boolean | ||
useDragInteraction Accessor StaticReadOnly | boolean | ||
useToolAsToolSettingsLabel Accessor StaticReadOnly | boolean | Use Tool Name As Tool Settings Widget Tab Label | |
viewOverlayDisplay Accessor StaticReadOnly | boolean | Returns the variable controlling whether the overlay is displayed in a Viewport | |
visibility Accessor StaticReadOnly | FrameworkVisibility | Manages UI visibility (Show/Hide) |
Defined in
Last Updated: 20 June, 2023