FrameworkChildWindows Interface
Beta
UiFramework.childWindows interface.
Methods
Name | Description | |
---|---|---|
close(childWindowId: string, processWindowClose?: boolean): boolean | Close a specific child window. | |
closeAll(): void | Close all child/pop-out windows. | |
find(childWindowId: undefined | string): undefined | OpenChildWindowInfo | Returns the OpenChildWindowInfo for the related id. | |
findId(contentWindow: undefined | | Window): undefined | string | Return the childWindowId of the provided window. | |
open(childWindowId: string, title: string, content: ReactNode, location: ChildWindowLocationProps, useDefaultPopoutUrl?: boolean): boolean | Open a new child window. |
Properties
Name | Type | Description | |
---|---|---|---|
openChildWindows Readonly | OpenChildWindowInfo[] | List of currently open child windows; |
Defined in
Last Updated: 20 June, 2023