FrameworkControls Interface
Beta
UiFramework.controls interface
Methods
Name | Description | |
---|---|---|
closeUi(): void | Closes all UI popups currently open | |
create(classId: string, uniqueId: string, options?: any, controlId?: string): undefined | ConfigurableUiElement | Creates a control registered by calling registerControl. | |
getWrapperElement(): HTMLElement | Gets the HTML wrapper element for Configurable UI | |
isRegistered(classId: string): boolean | Determines if a control has been registered based on its classId. | |
register(classId: string, constructor: ConfigurableUiControlConstructor): void | Registers a control implementing the ConfigurableUiElement interface. | |
unregister(classId: string): void | Unregisters a control that has been registered. |
Defined in
Last Updated: 20 June, 2023