FrameworkFrontstages Interface
Beta
UiFramework.frontstages interface
Methods
Name | Description | |
---|---|---|
addFrontstageProvider(frontstageProvider: FrontstageProvider): void | Add a Frontstage via a FrontstageProvider. | |
clearFrontstageDefs(): void | Clears the Frontstage map. | |
clearFrontstageProviders(): void | Clears the Frontstage Providers and the defs that may have been created from them. | |
closeModalFrontstage(): void | Closes the top-most modal Frontstage. | |
closeNestedFrontstage(): Promise<void> | Closes the top-most nested Frontstage. | |
deactivateFrontstageDef(): Promise<void> | Deactivates the active FrontstageDef. | |
findWidget(widgetId: string): undefined | WidgetDef | Finds a widget with the given id in the active frontstage | |
getFrontstageDef(id?: string): Promise<undefined | FrontstageDef> | Find a loaded Frontstage with a given id. | |
hasFrontstage(frontstageId: string): boolean | ||
openModalFrontstage(modalFrontstage: ModalFrontstageInfo): void | Opens a modal Frontstage. | |
openNestedFrontstage(nestedFrontstage: FrontstageDef): Promise<void> | Opens a nested Frontstage. | |
setActiveFrontstage(frontstageId: string): Promise<void> | Sets the active FrontstageDef give the stageId. | |
setActiveFrontstageDef(frontstageDef: undefined | FrontstageDef): Promise<void> | Sets the active FrontstageDef. | |
setActiveNavigationAid(navigationAidId: string, iModelConnection: IModelConnection): void | Sets the active Navigation Aid via its Id. | |
setActiveTool(tool: Tool): void | Sets the active tool | |
setActiveToolId(toolId: string): void | Sets the active tool id | |
setWidgetState(widgetId: string, state: WidgetState): boolean | Sets the state of the widget with the given id | |
updateModalFrontstage(): void | Updates the top-most modal Frontstage. |
Properties
Name | Type | Description | |
---|---|---|---|
activeFrontstageDef Readonly | undefined | FrontstageDef | Gets the active FrontstageDef. | |
activeFrontstageId Readonly | string | Gets the Id of the active FrontstageDef. | |
activeModalFrontstage Readonly | undefined | ModalFrontstageInfo | Gets the top-most modal Frontstage. | |
activeNestedFrontstage Readonly | undefined | FrontstageDef | Gets the top-most nested Frontstage. | |
activeToolId Readonly | string | Gets the Id of the active tool. | |
activeToolInformation Readonly | undefined | ToolInformation | Gets the active tool's ToolInformation | |
isLoading Readonly | boolean | Returns true if Frontstage is loading its controls. | |
modalFrontstageCount Readonly | number | Gets the number of modal Frontstages. | |
nestedFrontstageCount Readonly | number | Gets the number of nested Frontstages. | |
onCloseModalFrontstageRequestedEvent Readonly | Get Modal Frontstage Requested Closed event. | ||
onContentControlActivatedEvent Readonly | ContentControlActivatedEvent | Get Content Control Activated event. | |
onContentLayoutActivatedEvent Readonly | ContentLayoutActivatedEvent | Get Content Layout Activated event. | |
onFrontstageActivatedEvent Readonly | FrontstageActivatedEvent | Get Frontstage Activated event. | |
onFrontstageDeactivatedEvent Readonly | FrontstageDeactivatedEvent | Get Frontstage Deactivated event. | |
onFrontstageReadyEvent Readonly | FrontstageReadyEvent | Get Frontstage Activated event. | |
onModalFrontstageChangedEvent Readonly | ModalFrontstageChangedEvent | Get Modal Frontstage Changed event. | |
onModalFrontstageClosedEvent Readonly | ModalFrontstageClosedEvent | Get Modal Frontstage Closed event. | |
onNavigationAidActivatedEvent Readonly | NavigationAidActivatedEvent | Get Navigation Aid Activated event. | |
onPanelStateChangedEvent Readonly | PanelStateChangedEvent | Get Widget State Changed event. | |
onToolActivatedEvent Readonly | ToolActivatedEvent | Get Tool Activated event. | |
onToolIconChangedEvent Readonly | ToolIconChangedEvent | Get Tool Icon Changed event. | |
onToolSettingsReloadEvent Readonly | UiEvent<void> | Get ToolSetting Reload event. | |
onWidgetStateChangedEvent Readonly | WidgetStateChangedEvent | Get Widget State Changed event. |
Defined in
Last Updated: 20 June, 2023