WidgetDef Class
A Widget Definition in the 9-Zone Layout system.
Extended by
Methods
Name | Description | |
---|---|---|
constructor(): WidgetDef | ||
constructor(props: WidgetProps): WidgetDef | Deprecated | |
canOpen(): boolean | ||
getWidgetControl(type: ConfigurableUiControlType): undefined | WidgetControl | ||
onWidgetStateChanged(): void | ||
restoreTransientState(): boolean | Overwrite to restore transient DOM state. | |
saveTransientState(): void | Overwrite to save transient DOM state (i.e. | |
setCanPopout(value: undefined | boolean): void | ||
setFloatingContainerId(value: undefined | string): void | ||
setLabel(v: string | ConditionalStringValue | StringGetter): void | Set the label. | |
setTooltip(v: string | ConditionalStringValue | StringGetter): void | Set the tooltip. | |
setUpSyncSupport(props: WidgetProps): void | Deprecated | |
setWidgetState(newState: WidgetState): void | ||
createWidgetPropsFromAbstractProps(abstractWidgetProps: AbstractWidgetProps): WidgetProps Static | Deprecated | |
initializeFromWidgetProps(widgetProps: WidgetProps, me: WidgetDef): void Static | Deprecated |
Properties
Name | Type | Description | |
---|---|---|---|
activeState Accessor ReadOnly | WidgetState | ||
allowedPanelTargets Accessor | undefined | | ||
applicationData Accessor ReadOnly | any | ||
badgeType Accessor ReadOnly | undefined | BadgeType | ||
canPopout Accessor ReadOnly | undefined | boolean | ||
classId Accessor ReadOnly | undefined | string | ConfigurableUiControlConstructor | ||
fillZone Accessor ReadOnly | boolean | ||
floatingContainerId Accessor ReadOnly | undefined | string | ||
hideWithUiWhenFloating Accessor | boolean | ||
iconSpec Accessor | IconSpec | ||
id Accessor ReadOnly | string | ||
initialProps Accessor ReadOnly | undefined | WidgetProps | ||
isActive Accessor ReadOnly | boolean | ||
isFloating Accessor ReadOnly | boolean | ||
isFloatingStateSupported Accessor ReadOnly | boolean | ||
isFloatingStateWindowResizable Accessor ReadOnly | boolean | ||
isFreeform Accessor ReadOnly | boolean | ||
isStatusBar Accessor ReadOnly | boolean | ||
isToolSettings Accessor ReadOnly | boolean | ||
isVisible Accessor ReadOnly | boolean | ||
label Accessor ReadOnly | string | Get the label string | |
priority Accessor ReadOnly | number | ||
reactNode Accessor | ReactNode | ||
state Accessor ReadOnly | WidgetState | ||
stateChanged Accessor ReadOnly | boolean | ||
stateFunc Accessor ReadOnly | undefined | WidgetStateFunc | ||
syncEventIds Accessor ReadOnly | string[] | ||
tooltip Accessor ReadOnly | string | Get the tooltip string | |
widgetControl Accessor ReadOnly | undefined | WidgetControl | ||
widgetType Accessor | WidgetType |
Defined in
Last Updated: 20 June, 2023