WidgetProps Interface
Deprecated in 3.5. Props of a deprecated component.
Properties for a Widget component.
Extends
- Omit<AbstractWidgetProps, "getWidgetContent">
- IconProps
Inherited methods
Properties
Name | Type | Description | |
---|---|---|---|
classId | string | ConfigurableUiControlConstructor | Control's class id | |
control | undefined | ConfigurableUiControlConstructor | A WidgetControl providing information about the Widget. | |
element | undefined | ReactNode | A React component for the Widget. | |
labelKey | undefined | string | if set, it is used to define a key that is used to look up a localized string. | |
preferredPanelSize | undefined | "fit-content" | ||
tooltipKey | undefined | string | if set, it is used to define a key that is used to look up a localized string. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
allowedPanelTargets Readonly | undefined | | Omit | Optional prop specifying which Panel sides can be docking targets for this widget. |
applicationData Readonly | undefined | any | Omit | Application data attached to the Widget. |
badgeType Readonly | undefined | BadgeType | Omit | Badge to be overlaid on the widget tab. |
canPopout Readonly | undefined | boolean | Omit | Indicates if widget can be popped out to a child window. |
className | undefined | string | IconProps | Custom CSS class name |
defaultFloatingPosition Readonly | undefined | { x: number, y: number } | Omit | Defines that default Top Left position when widget is floated via API calls |
defaultFloatingSize | undefined | { height: number, width: number } | Omit | Optional default size to use when floating a widget. |
defaultState Readonly | undefined | WidgetState | Omit | Default Widget state. |
fillZone Readonly | undefined | boolean | Omit | Indicates whether this Widget should fill the available space in the Zone. |
floatingContainerId Readonly | undefined | string | Omit | If the widget state is changed to floating and the floatingContainerId is defined, the widget will be added to a |
hideWithUiWhenFloating | undefined | boolean | Omit | Optional prop that tells the widget system to fade this widget out with the rest of the UI when it is in floating state |
icon Readonly | string | ConditionalStringValue | Omit | Name of icon WebFont entry or if specifying an imported SVG symbol use "webSvg:" prefix to imported symbol Id. |
iconSpec | undefined | IconSpec | IconProps | CSS class name or SvgSprite/SvgPath for icon. |
id Readonly | undefined | string | Omit | Id used to uniquely identify the widget. |
internalData Readonly | undefined | Map<string, any> | Omit | optional data to used by item implementor. |
isFloatingStateSupported Readonly | undefined | boolean | Omit | Indicates if widget can be in floating state, default to true. |
isFloatingStateWindowResizable Readonly | undefined | boolean | Omit | Indicates if floating widget is resizable, defaults to false which caused the widget to be auto-sized.. |
isFreeform Readonly | undefined | boolean | Omit | Indicates whether the Widget is free-form or rectangular. |
isStatusBar Readonly | undefined | boolean | Omit | Indicates whether this Widget is for the Status Bar. |
isToolSettings Readonly | undefined | boolean | Omit | Indicates whether this Widget is for the Tool Settings. |
itemId | undefined | string | IconProps | Optional unique identifier for item. |
label Readonly | string | ConditionalStringValue | Omit | if set, component will be considered selected but will NOT display an "active stripe" - defaults to false. |
priority Readonly | undefined | number | Omit | Widget priority |
providerId Readonly | undefined | string | Omit | id of UiItemsProvider |
style | undefined | CSSProperties | IconProps | Custom CSS style properties |
syncEventIds Readonly | undefined | string[] | Omit | Defines the SyncUi event Ids that will trigger the stateFunc to run to determine the state of the widget. |
tooltip Readonly | string | ConditionalStringValue | Omit | used to explicitly set the tooltip shown by a component. |
Defined in
Last Updated: 20 June, 2023