Properties for a Widget.
Extends
Methods
Name |
Description |
|
getWidgetContent(): any Readonly |
Gets the widget content. |
|
onWidgetStateChanged(): void OptionalReadonly |
Handler for widget state changed event |
|
restoreTransientState(): boolean OptionalReadonly |
Restore transient DOM state. |
|
saveTransientState(): void OptionalReadonly |
Save transient DOM state (i.e. |
|
stateFunc(state: Readonly<WidgetState>): WidgetState OptionalReadonly |
Function executed to determine the state of the widget. |
Deprecated |
Properties
Name |
Type |
Description |
|
allowedPanelTargets Readonly |
undefined | |
Optional prop specifying which Panel sides can be docking targets for this widget. |
|
applicationData Readonly |
undefined | any |
Application data attached to the Widget. |
|
badgeType Readonly |
undefined | BadgeType |
Badge to be overlaid on the widget tab. |
|
canPopout Readonly |
undefined | boolean |
Indicates if widget can be popped out to a child window. |
|
defaultFloatingPosition Readonly |
undefined | { x: number, y: number } |
Defines that default Top Left position when widget is floated via API calls |
|
defaultFloatingSize |
undefined | { height: number, width: number } |
Optional default size to use when floating a widget. |
|
defaultState Readonly |
undefined | WidgetState |
Default Widget state. |
|
fillZone Readonly |
undefined | boolean |
Indicates whether this Widget should fill the available space in the Zone. |
|
floatingContainerId Readonly |
undefined | string |
If the widget state is changed to floating and the floatingContainerId is defined, the widget will be added to a |
|
hideWithUiWhenFloating |
undefined | boolean |
Optional prop that tells the widget system to fade this widget out with the rest of the UI when it is in floating state |
|
icon Readonly |
string | ConditionalStringValue |
Name of icon WebFont entry or if specifying an imported SVG symbol use "webSvg:" prefix to imported symbol Id. |
|
id Readonly |
undefined | string |
Id used to uniquely identify the widget. |
|
internalData Readonly |
undefined | Map<string, any> |
optional data to used by item implementor. |
|
isFloatingStateSupported Readonly |
undefined | boolean |
Indicates if widget can be in floating state, default to true. |
|
isFloatingStateWindowResizable Readonly |
undefined | boolean |
Indicates if floating widget is resizable, defaults to false which caused the widget to be auto-sized.. |
|
isFreeform Readonly |
undefined | boolean |
Indicates whether the Widget is free-form or rectangular. |
Deprecated |
isStatusBar Readonly |
undefined | boolean |
Indicates whether this Widget is for the Status Bar. |
|
isToolSettings Readonly |
undefined | boolean |
Indicates whether this Widget is for the Tool Settings. |
|
label Readonly |
string | ConditionalStringValue |
if set, component will be considered selected but will NOT display an "active stripe" - defaults to false. |
|
priority Readonly |
undefined | number |
Widget priority |
|
syncEventIds Readonly |
undefined | string[] |
Defines the SyncUi event Ids that will trigger the stateFunc to run to determine the state of the widget. |
|
tooltip Readonly |
string | ConditionalStringValue |
used to explicitly set the tooltip shown by a component. |
|
Inherited properties
Name |
Type |
Inherited from |
Description |
providerId Readonly |
undefined | string |
ProvidedItem |
id of UiItemsProvider |
Defined in
Last Updated:
20 June, 2023