ToolbarWidgetDefBase Class
Deprecated in 3.0. UI 1.0 will be removed in AppUi 4.0.
A Toolbar Widget normally displayed in the top left & top right zones in the 9-Zone Layout system.
Extends
Extended by
Methods
Name | Description | |
---|---|---|
constructor(def: ToolbarWidgetProps): ToolbarWidgetDefBase | ||
renderHorizontalToolbar(): ReactNode | ||
renderVerticalToolbar(): ReactNode |
Inherited methods
Name | Inherited from | Description |
---|---|---|
canOpen(): boolean | WidgetDef | |
getWidgetControl(type: ConfigurableUiControlType): undefined | WidgetControl | WidgetDef | |
onWidgetStateChanged(): void | WidgetDef | |
restoreTransientState(): boolean | WidgetDef | Overwrite to restore transient DOM state. |
saveTransientState(): void | WidgetDef | Overwrite to save transient DOM state (i.e. |
setCanPopout(value: undefined | boolean): void | WidgetDef | |
setFloatingContainerId(value: undefined | string): void | WidgetDef | |
setLabel(v: string | ConditionalStringValue | StringGetter): void | WidgetDef | Set the label. |
setTooltip(v: string | ConditionalStringValue | StringGetter): void | WidgetDef | Set the tooltip. |
setUpSyncSupport(props: WidgetProps): void | WidgetDef | |
setWidgetState(newState: WidgetState): void | WidgetDef | |
createWidgetPropsFromAbstractProps(abstractWidgetProps: AbstractWidgetProps): WidgetProps Static | WidgetDef | |
initializeFromWidgetProps(widgetProps: WidgetProps, me: WidgetDef): void Static | WidgetDef |
Properties
Name | Type | Description | |
---|---|---|---|
horizontalDirection | Direction | ||
horizontalItems | undefined | ItemList | ||
horizontalPanelAlignment | ToolbarPanelAlignment | ||
verticalDirection | Direction | ||
verticalItems | undefined | ItemList | ||
verticalPanelAlignment | ToolbarPanelAlignment | ||
widgetBaseName Accessor | string |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
activeState Accessor ReadOnly | WidgetState | WidgetDef | |
allowedPanelTargets Accessor | undefined | | WidgetDef | |
applicationData Accessor ReadOnly | any | WidgetDef | |
badgeType Accessor ReadOnly | undefined | BadgeType | WidgetDef | |
canPopout Accessor ReadOnly | undefined | boolean | WidgetDef | |
classId Accessor ReadOnly | undefined | string | ConfigurableUiControlConstructor | WidgetDef | |
fillZone Accessor ReadOnly | boolean | WidgetDef | |
floatingContainerId Accessor ReadOnly | undefined | string | WidgetDef | |
hideWithUiWhenFloating Accessor | boolean | WidgetDef | |
iconSpec Accessor | IconSpec | WidgetDef | |
id Accessor ReadOnly | string | WidgetDef | |
initialProps Accessor ReadOnly | undefined | WidgetProps | WidgetDef | |
isActive Accessor ReadOnly | boolean | WidgetDef | |
isFloating Accessor ReadOnly | boolean | WidgetDef | |
isFloatingStateSupported Accessor ReadOnly | boolean | WidgetDef | |
isFloatingStateWindowResizable Accessor ReadOnly | boolean | WidgetDef | |
isFreeform Accessor ReadOnly | boolean | WidgetDef | |
isStatusBar Accessor ReadOnly | boolean | WidgetDef | |
isToolSettings Accessor ReadOnly | boolean | WidgetDef | |
isVisible Accessor ReadOnly | boolean | WidgetDef | |
label Accessor ReadOnly | string | WidgetDef | Get the label string |
priority Accessor ReadOnly | number | WidgetDef | |
reactNode Accessor | ReactNode | WidgetDef | |
state Accessor ReadOnly | WidgetState | WidgetDef | |
stateChanged Accessor ReadOnly | boolean | WidgetDef | |
stateFunc Accessor ReadOnly | undefined | WidgetStateFunc | WidgetDef | |
syncEventIds Accessor ReadOnly | string[] | WidgetDef | |
tooltip Accessor ReadOnly | string | WidgetDef | Get the tooltip string |
widgetControl Accessor ReadOnly | undefined | WidgetControl | WidgetDef | |
widgetType Accessor | WidgetType | WidgetDef |
Defined in
Last Updated: 20 June, 2023