NavigationWidgetDef Class
Deprecated in 2.x. Use NavigationWidgetComposer instead
Definition of a Navigation Widget normally displayed in the top right zone in the 9-Zone Layout system.
Extends
Methods
Name | Description | |
---|---|---|
constructor(props: NavigationWidgetProps): NavigationWidgetDef | ||
renderCornerItem(): ReactNode | ||
updateNavigationAid(navigationAidId: string, imodel?: IModelConnection): void |
Inherited methods
Properties
Name | Type | Description | |
---|---|---|---|
reactNode Accessor ReadOnly | ReactNode |
Inherited properties
Defined in
Last Updated: 20 June, 2023