NavigationWidgetProps Interface
Deprecated in 3.5. UI 1.0 will be removed in AppUi 4.0
Properties for a Navigation Widget.
Extends
Inherited methods
Name | Inherited from | Description |
---|---|---|
onWidgetStateChanged(): void OptionalReadonly | ToolbarWidgetProps | Handler for widget state changed event |
restoreTransientState(): boolean OptionalReadonly | ToolbarWidgetProps | Restore transient DOM state. |
saveTransientState(): void OptionalReadonly | ToolbarWidgetProps | Save transient DOM state (i.e. |
stateFunc(state: Readonly<WidgetState>): WidgetState OptionalReadonly | ToolbarWidgetProps | Function executed to determine the state of the widget. |
Properties
Name | Type | Description | |
---|---|---|---|
navigationAidId | undefined | string |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
allowedPanelTargets Readonly | undefined | | ToolbarWidgetProps | Optional prop specifying which Panel sides can be docking targets for this widget. |
applicationData Readonly | undefined | any | ToolbarWidgetProps | Application data attached to the Widget. |
badgeType Readonly | undefined | BadgeType | ToolbarWidgetProps | Badge to be overlaid on the widget tab. |
canPopout Readonly | undefined | boolean | ToolbarWidgetProps | Indicates if widget can be popped out to a child window. |
classId | string | ConfigurableUiControlConstructor | ToolbarWidgetProps | Control's class id |
className | undefined | string | ToolbarWidgetProps | Custom CSS class name |
control | undefined | ConfigurableUiControlConstructor | ToolbarWidgetProps | A WidgetControl providing information about the Widget. |
defaultFloatingPosition Readonly | undefined | { x: number, y: number } | ToolbarWidgetProps | Defines that default Top Left position when widget is floated via API calls |
defaultFloatingSize | undefined | { height: number, width: number } | ToolbarWidgetProps | Optional default size to use when floating a widget. |
defaultState Readonly | undefined | WidgetState | ToolbarWidgetProps | Default Widget state. |
element | undefined | ReactNode | ToolbarWidgetProps | A React component for the Widget. |
fillZone Readonly | undefined | boolean | ToolbarWidgetProps | Indicates whether this Widget should fill the available space in the Zone. |
floatingContainerId Readonly | undefined | string | ToolbarWidgetProps | If the widget state is changed to floating and the floatingContainerId is defined, the widget will be added to a |
hideWithUiWhenFloating | undefined | boolean | ToolbarWidgetProps | Optional prop that tells the widget system to fade this widget out with the rest of the UI when it is in floating state |
horizontalDirection | undefined | Direction | ToolbarWidgetProps | |
horizontalItems | undefined | ItemList | ToolbarWidgetProps | |
icon Readonly | string | ConditionalStringValue | ToolbarWidgetProps | Name of icon WebFont entry or if specifying an imported SVG symbol use "webSvg:" prefix to imported symbol Id. |
iconSpec | undefined | IconSpec | ToolbarWidgetProps | CSS class name or SvgSprite/SvgPath for icon. |
id Readonly | undefined | string | ToolbarWidgetProps | Id used to uniquely identify the widget. |
internalData Readonly | undefined | Map<string, any> | ToolbarWidgetProps | optional data to used by item implementor. |
isFloatingStateSupported Readonly | undefined | boolean | ToolbarWidgetProps | Indicates if widget can be in floating state, default to true. |
isFloatingStateWindowResizable Readonly | undefined | boolean | ToolbarWidgetProps | Indicates if floating widget is resizable, defaults to false which caused the widget to be auto-sized.. |
isFreeform Readonly | undefined | boolean | ToolbarWidgetProps | Indicates whether the Widget is free-form or rectangular. |
isStatusBar Readonly | undefined | boolean | ToolbarWidgetProps | Indicates whether this Widget is for the Status Bar. |
isToolSettings Readonly | undefined | boolean | ToolbarWidgetProps | Indicates whether this Widget is for the Tool Settings. |
itemId | undefined | string | ToolbarWidgetProps | Optional unique identifier for item. |
label Readonly | string | ConditionalStringValue | ToolbarWidgetProps | if set, component will be considered selected but will NOT display an "active stripe" - defaults to false. |
labelKey | undefined | string | ToolbarWidgetProps | if set, it is used to define a key that is used to look up a localized string. |
preferredPanelSize | undefined | "fit-content" | ToolbarWidgetProps | |
priority Readonly | undefined | number | ToolbarWidgetProps | Widget priority |
providerId Readonly | undefined | string | ToolbarWidgetProps | id of UiItemsProvider |
style | undefined | CSSProperties | ToolbarWidgetProps | Custom CSS style properties |
syncEventIds Readonly | undefined | string[] | ToolbarWidgetProps | Defines the SyncUi event Ids that will trigger the stateFunc to run to determine the state of the widget. |
tooltip Readonly | string | ConditionalStringValue | ToolbarWidgetProps | used to explicitly set the tooltip shown by a component. |
tooltipKey | undefined | string | ToolbarWidgetProps | if set, it is used to define a key that is used to look up a localized string. |
verticalDirection | undefined | Direction | ToolbarWidgetProps | |
verticalItems | undefined | ItemList | ToolbarWidgetProps |
Defined in
Last Updated: 20 June, 2023