ToolbarWidgetProps Interface
Deprecated in 3.5. UI 1.0 will be removed in AppUi 4.0.
Properties for a Toolbar Widget.
Extends
Inherited methods
Name | Inherited from | Description |
---|---|---|
onWidgetStateChanged(): void OptionalReadonly | WidgetProps | Handler for widget state changed event |
restoreTransientState(): boolean OptionalReadonly | WidgetProps | Restore transient DOM state. |
saveTransientState(): void OptionalReadonly | WidgetProps | Save transient DOM state (i.e. |
stateFunc(state: Readonly<WidgetState>): WidgetState OptionalReadonly | WidgetProps | Function executed to determine the state of the widget. |
Properties
Name | Type | Description | |
---|---|---|---|
horizontalDirection | undefined | Direction | ||
horizontalItems | undefined | ItemList | ||
verticalDirection | undefined | Direction | ||
verticalItems | undefined | ItemList |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
allowedPanelTargets Readonly | undefined | | WidgetProps | Optional prop specifying which Panel sides can be docking targets for this widget. |
applicationData Readonly | undefined | any | WidgetProps | Application data attached to the Widget. |
badgeType Readonly | undefined | BadgeType | WidgetProps | Badge to be overlaid on the widget tab. |
canPopout Readonly | undefined | boolean | WidgetProps | Indicates if widget can be popped out to a child window. |
classId | string | ConfigurableUiControlConstructor | WidgetProps | Control's class id |
className | undefined | string | WidgetProps | Custom CSS class name |
control | undefined | ConfigurableUiControlConstructor | WidgetProps | A WidgetControl providing information about the Widget. |
defaultFloatingPosition Readonly | undefined | { x: number, y: number } | WidgetProps | Defines that default Top Left position when widget is floated via API calls |
defaultFloatingSize | undefined | { height: number, width: number } | WidgetProps | Optional default size to use when floating a widget. |
defaultState Readonly | undefined | WidgetState | WidgetProps | Default Widget state. |
element | undefined | ReactNode | WidgetProps | A React component for the Widget. |
fillZone Readonly | undefined | boolean | WidgetProps | Indicates whether this Widget should fill the available space in the Zone. |
floatingContainerId Readonly | undefined | string | WidgetProps | If the widget state is changed to floating and the floatingContainerId is defined, the widget will be added to a |
hideWithUiWhenFloating | undefined | boolean | WidgetProps | Optional prop that tells the widget system to fade this widget out with the rest of the UI when it is in floating state |
icon Readonly | string | ConditionalStringValue | WidgetProps | Name of icon WebFont entry or if specifying an imported SVG symbol use "webSvg:" prefix to imported symbol Id. |
iconSpec | undefined | IconSpec | WidgetProps | CSS class name or SvgSprite/SvgPath for icon. |
id Readonly | undefined | string | WidgetProps | Id used to uniquely identify the widget. |
internalData Readonly | undefined | Map<string, any> | WidgetProps | optional data to used by item implementor. |
isFloatingStateSupported Readonly | undefined | boolean | WidgetProps | Indicates if widget can be in floating state, default to true. |
isFloatingStateWindowResizable Readonly | undefined | boolean | WidgetProps | Indicates if floating widget is resizable, defaults to false which caused the widget to be auto-sized.. |
isFreeform Readonly | undefined | boolean | WidgetProps | Indicates whether the Widget is free-form or rectangular. |
isStatusBar Readonly | undefined | boolean | WidgetProps | Indicates whether this Widget is for the Status Bar. |
isToolSettings Readonly | undefined | boolean | WidgetProps | Indicates whether this Widget is for the Tool Settings. |
itemId | undefined | string | WidgetProps | Optional unique identifier for item. |
label Readonly | string | ConditionalStringValue | WidgetProps | if set, component will be considered selected but will NOT display an "active stripe" - defaults to false. |
labelKey | undefined | string | WidgetProps | if set, it is used to define a key that is used to look up a localized string. |
preferredPanelSize | undefined | "fit-content" | WidgetProps | |
priority Readonly | undefined | number | WidgetProps | Widget priority |
providerId Readonly | undefined | string | WidgetProps | id of UiItemsProvider |
style | undefined | CSSProperties | WidgetProps | Custom CSS style properties |
syncEventIds Readonly | undefined | string[] | WidgetProps | Defines the SyncUi event Ids that will trigger the stateFunc to run to determine the state of the widget. |
tooltip Readonly | string | ConditionalStringValue | WidgetProps | used to explicitly set the tooltip shown by a component. |
tooltipKey | undefined | string | WidgetProps | if set, it is used to define a key that is used to look up a localized string. |
Defined in
Last Updated: 20 June, 2023