FrameworkBackstage Interface
UiFramework.backstage interface.
Methods
Name | Description | |
---|---|---|
close(): void | Hides the backstage. | |
getBackstageToggleCommand(overrideIconSpec?: IconSpec): CommandItemDef | Creates a CommandItemDef that toggle the backstage. | |
open(): void | Display the backstage. | |
toggle(): void | Toggle the backstage. |
Properties
Name | Type | Description | |
---|---|---|---|
isOpen Readonly | boolean | State of the backstage. | |
onToggled Readonly | BeEvent<(args: BackstageToggledArgs) => void> | Event activated when the backstage is toggled. |
Defined in
Last Updated: 20 June, 2023