CommandItemDef Class
An Item that executes a Command.
Extends
Methods
Name | Description | |
---|---|---|
constructor(commandItemProps: CommandItemProps, onItemExecuted?: OnItemExecutedFunc): CommandItemDef |
Inherited methods
Name | Inherited from | Description |
---|---|---|
execute(): void | ActionButtonItemDef | Called when the action button is invoked by a click or touch |
getDimension(orientation: Orientation): number | ActionButtonItemDef | Determines the dimension in a given orientation |
handleSizeKnown(size: SizeProps): void | ActionButtonItemDef | Called when the size of the action button is initialized and the size is known |
setDescription(v: string | ConditionalStringValue | StringGetter): void | ActionButtonItemDef | Set the description. |
setLabel(v: string | ConditionalStringValue | StringGetter): void | ActionButtonItemDef | Set the label. |
setTooltip(v: string | ConditionalStringValue | StringGetter): void | ActionButtonItemDef | Set the tooltip. |
initializeDef(me: ItemDefBase, itemProps: ItemProps): void Static | ActionButtonItemDef |
Properties
Name | Type | Description | |
---|---|---|---|
commandId | string | ||
commandIdPrefix Static | string | ||
id Accessor ReadOnly | string |
Inherited properties
Defined in
Last Updated: 20 June, 2023