ConditionalBooleanValue Class
Class used to return a boolean value. The boolean value is refreshed by using the specified function. The syncEventIds define one or more eventIds that would require the testFunc to be rerun.
Methods
Name | Description | |
---|---|---|
constructor(testFunc: () => boolean, syncEventIds: string[], value?: boolean): ConditionalBooleanValue | Constructor for ConditionalBooleanValue. | |
refresh(): boolean | Called to update the value by running the testFunc | |
getValue(conditionalValue: undefined | boolean | ConditionalBooleanValue): boolean Static | helper function to get boolean from a ConditionalBooleanValue | boolean | undefined | |
refreshValue(conditionalValue: undefined | boolean | ConditionalBooleanValue, eventIds: Set<string>): boolean Static | helper function to process properties defined as type ConditionalBooleanValue | boolean | undefined |
Properties
Name | Type | Description | |
---|---|---|---|
syncEventIds Readonly | string[] | ||
testFunc Readonly | () => boolean | ||
value Accessor ReadOnly | boolean | The current boolean value of the conditional. |
Defined in
Last Updated: 20 June, 2023