CommandItemProps Interface
Properties for a Command item.
Extends
Inherited methods
Properties
Name |
Type |
Description |
|
commandId |
undefined | string |
|
|
Inherited properties
Name |
Type |
Inherited from |
Description |
applicationData |
undefined | any |
ItemProps |
can be used by application to store miscellaneous data. |
badgeType |
undefined | BadgeType |
ItemProps |
Badge to be overlaid on the item. |
className |
undefined | string |
ItemProps |
Custom CSS class name |
description |
string | ConditionalStringValue | StringGetter |
ItemProps |
if set, it is used to explicitly set the description shown by a component. |
descriptionKey |
undefined | string |
ItemProps |
if set, it is used to define a key that is used to look up a localized string. |
icon |
string | ConditionalStringValue |
ItemProps |
abstract icon definition, used when create itemDef from abstract item (ie. |
iconSpec |
undefined | IconSpec |
ItemProps |
CSS class name or SvgSprite/SvgPath for icon. |
isActive |
undefined | boolean |
ItemProps |
if set, component will be considered "active" an will display an "active stripe" - defaults to false |
isDisabled |
boolean | ConditionalBooleanValue |
ItemProps |
if true component will be disabled - defaults to false |
isEnabled |
undefined | boolean |
ItemProps |
if set, component will be enabled - defaults to true |
isHidden |
boolean | ConditionalBooleanValue |
ItemProps |
if true component will be hidden - defaults to false |
isPressed |
undefined | boolean |
ItemProps |
if set, component will be considered selected but will NOT display an "active stripe" - defaults to false. |
isVisible |
undefined | boolean |
ItemProps |
if set, component will be visible - defaults to true |
itemId |
undefined | string |
ItemProps |
Optional unique identifier for item. |
label |
string | ConditionalStringValue | StringGetter |
ItemProps |
if set, it is used to explicitly set the label shown by a component. |
labelKey |
undefined | string |
ItemProps |
if set, it is used to define a key that is used to look up a localized string. |
parameters |
undefined | any |
CommandHandler |
Parameters passed to the function |
stateSyncIds |
undefined | string[] |
ItemProps |
Synchronize Ids to listen for |
style |
undefined | CSSProperties |
ItemProps |
Custom CSS style properties |
tooltip |
string | ConditionalStringValue | StringGetter |
ItemProps |
used to explicitly set the tooltip shown by a component. |
tooltipKey |
undefined | string |
ItemProps |
if set, it is used to define a key that is used to look up a localized string. |
Defined in
Last Updated:
20 June, 2023