ItemDefBase Class
The base class for Items.
Extended by
Methods
Name | Description | |
---|---|---|
constructor(itemProps: ItemProps): ItemDefBase | ||
setDescription(v: string | ConditionalStringValue | StringGetter): void | Set the description. | |
setLabel(v: string | ConditionalStringValue | StringGetter): void | Set the label. | |
setTooltip(v: string | ConditionalStringValue | StringGetter): void | Set the tooltip. | |
initializeDef(me: ItemDefBase, itemProps: ItemProps): void Static |
Properties
Name | Type | Description | |
---|---|---|---|
applicationData | undefined | any | ||
badgeType | undefined | BadgeType | ||
description Accessor ReadOnly | string | Get the description string | |
iconElement | undefined | ReactNode | ||
iconSpec | undefined | IconSpec | ||
id Accessor AbstractReadOnly | string | ||
isActive Accessor | boolean | ||
isDisabled | boolean | ConditionalBooleanValue | ||
isEnabled | boolean | Deprecated | |
isHidden | boolean | ConditionalBooleanValue | ||
isPressed | boolean | ||
isVisible | boolean | Deprecated | |
label Accessor ReadOnly | string | Get the label string | |
rawLabel Accessor ReadOnly | string | ConditionalStringValue | StringGetter | Get the label string | |
stateFunc | undefined | (state: Readonly<BaseItemState>) => BaseItemState | ||
stateSyncIds | string[] | Deprecated | |
tooltip Accessor ReadOnly | string | Get the tooltip string | |
trayId Accessor ReadOnly | undefined |
Defined in
Last Updated: 20 June, 2023