FrameworkKeyboardShortcut Interface
Keyboard Shortcut used to execute an action
Extends
Methods
Name | Description | |
---|---|---|
getShortcut(mapKey: string): undefined | FrameworkKeyboardShortcut | Finds a shortcut with a given key in the shortcut's container | |
itemPicked(): void | Called when the ActionButtonItemDef associated with this shortcut is invoked |
Inherited methods
Name | Inherited from | Description |
---|---|---|
setDescription(v: string | ConditionalStringValue | StringGetter): void | ItemDefBase | Set the description. |
setLabel(v: string | ConditionalStringValue | StringGetter): void | ItemDefBase | Set the label. |
setTooltip(v: string | ConditionalStringValue | StringGetter): void | ItemDefBase | Set the tooltip. |
Properties
Name | Type | Description | |
---|---|---|---|
id Readonly | string | Returns the id for this shortcut | |
isAltKeyRequired Readonly | boolean | Gets whether the Alt key required. | |
isCtrlKeyRequired Readonly | boolean | Gets whether the Ctrl key required. | |
isFunctionKey Readonly | boolean | Gets whether this is a Function key. | |
isShiftKeyRequired Readonly | boolean | Gets whether the Shift key required. | |
isSpecialKey Readonly | boolean | Gets whether this is a Special key. | |
item Readonly | undefined | ActionButtonItemDef | Returns the ActionButtonItemDef associated with this shortcut | |
key Readonly | string | Gets the keyboard key | |
keyMapKey Readonly | string | Returns the shortcut's key map key used as the id | |
shortcutContainer Readonly | FrameworkKeyboardShortcutContainer | Returns the shortcut container |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
applicationData | undefined | any | ItemDefBase | |
badgeType | undefined | BadgeType | ItemDefBase | |
iconElement | undefined | ReactNode | ItemDefBase | |
iconSpec | undefined | IconSpec | ItemDefBase | |
isDisabled | boolean | ConditionalBooleanValue | ItemDefBase | |
isEnabled | boolean | ItemDefBase | |
isHidden | boolean | ConditionalBooleanValue | ItemDefBase | |
isPressed | boolean | ItemDefBase | |
isVisible | boolean | ItemDefBase | |
stateFunc | undefined | (state: Readonly<BaseItemState>) => BaseItemState | ItemDefBase | |
stateSyncIds | string[] | ItemDefBase | |
description Accessor ReadOnly | string | ItemDefBase | Get the description string |
isActive Accessor | boolean | ItemDefBase | |
label Accessor ReadOnly | string | ItemDefBase | Get the label string |
rawLabel Accessor ReadOnly | string | ConditionalStringValue | StringGetter | ItemDefBase | Get the label string |
tooltip Accessor ReadOnly | string | ItemDefBase | Get the tooltip string |
trayId Accessor ReadOnly | undefined | ItemDefBase |
Defined in
Last Updated: 20 June, 2023