FrameworkKeyboardShortcutContainer Interface
Keyboard Shortcut Container
Methods
Name | Description | |
---|---|---|
areKeyboardShortcutsAvailable(): boolean | Determines if any Keyboard Shortcuts are available in this container | |
emptyData(): void | Empties any Keyboard Shortcuts from this container | |
findKey(keyMapKey: string): undefined | FrameworkKeyboardShortcut | Finds a Keyboard Shortcut associated with a given key | |
getAvailableKeyboardShortcuts(): FrameworkKeyboardShortcut[] | ||
registerKey(keyMapKey: string, inShortcut: FrameworkKeyboardShortcut): undefined | FrameworkKeyboardShortcut | Registers a Keyboard Shortcut associated with a given key in the managed list | |
showShortcutsMenu(): void | Displays a menu for the Keyboard Shortcuts in this container |
Defined in
Last Updated: 20 June, 2023