ConditionalFieldProps Interface
Properties supported by ConditionalField component.
Extends
Methods
Name | Description | |
---|---|---|
boolFunc(props: StatusFieldProps & { isInFooterMode: boolean }): boolean | Function to be called to return a boolean value. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
onOpenWidget(widget: StatusBarFieldId): void Optional | StatusFieldProps | Function called when the widget is opened or closed. |
Properties
Name | Type | Description | |
---|---|---|---|
defaultValue | undefined | boolean | Optional, default/initial boolean value that is saved in the components state. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
className | undefined | string | StatusFieldProps | Custom CSS class name |
isInFooterMode | undefined | boolean | StatusFieldProps | Indicates whether the StatusBar is in footer mode |
itemId | undefined | string | StatusFieldProps | Optional unique identifier for item. |
openWidget | undefined | StatusBarFieldId | StatusFieldProps | Field Id for open widgets |
style | undefined | CSSProperties | StatusFieldProps | Custom CSS style properties |
Defined in
Last Updated: 20 June, 2023