StatusFieldProps Interface
Properties for a StatusBar field component
Extends
Methods
Name | Description | |
---|---|---|
onOpenWidget(widget: StatusBarFieldId): void Optional | Function called when the widget is opened or closed. | Deprecated |
Properties
Name | Type | Description | |
---|---|---|---|
isInFooterMode | undefined | boolean | Indicates whether the StatusBar is in footer mode | Deprecated |
openWidget | undefined | StatusBarFieldId | Field Id for open widgets | Deprecated |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
className | undefined | string | CommonProps | Custom CSS class name |
itemId | undefined | string | CommonProps | Optional unique identifier for item. |
style | undefined | CSSProperties | CommonProps | Custom CSS style properties |
Defined in
Last Updated: 20 June, 2023