SessionState Interface
The portion of state managed by the SessionStateReducer.
Properties
Name | Type | Description | |
---|---|---|---|
activeSelectionScope | string | ||
availableSelectionScopes | PresentationSelectionScope[] | ||
cursorMenuData | undefined | CursorMenuData | ||
defaultIModelViewportControlId | undefined | string | ||
defaultViewId | undefined | string | ||
defaultViewState | any | ||
iModelConnection | any | ||
iModelId | string | ||
numItemsSelected | number |
Defined in
Last Updated: 20 June, 2023