FloatingViewportContentControl Class
Beta
Extends
Methods
Name | Description | |
---|---|---|
constructor(uniqueId: string, name: string, node: ReactNode): FloatingViewportContentControl | Creates an instance of ViewportContentControl. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
getKeyedReactNode(): ReactNode Protected | ViewportContentControl | |
getReactElementForViewSelectorChange(_iModel: IModelConnection, _viewDefinitionId: string, _viewState: ViewState, _name: string): ReactNode | ViewportContentControl | Get the React.Element for a ViewSelector change. |
getReactNode(): ReactNode Protected | ViewportContentControl | |
getType(): ConfigurableUiControlType | ViewportContentControl | Gets the type of ConfigurableUiControl, which is 'Viewport' in this case |
onActivated(): void | ViewportContentControl | Called when this ContentControl is activated |
onDeactivated(): void | ViewportContentControl | Called when this ContentControl is deactivated |
onFrontstageDeactivated(): void | ViewportContentControl | Called when Frontstage is deactivated. |
onFrontstageReady(): void | ViewportContentControl | Called when Frontstage is ready. |
onInitialize(): void | ViewportContentControl | Called to initialize the ConfigurableUiControl. |
processViewSelectorChange(iModel: IModelConnection, viewDefinitionId: string, viewState: ViewState, name: string): Promise<void> | ViewportContentControl | Process a ViewSelector change. |
setIsReady(): void | ViewportContentControl | Returns a promise that resolves when the control is ready for usage. |
Properties
Name | Type | Description | |
---|---|---|---|
reactNode Accessor | ReactNode | The React node associated with this control. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
_appDataOptions Protected | any | ViewportContentControl | |
_reactNode Protected | ReactNode | ViewportContentControl | |
applicationData Accessor ReadOnly | any | ViewportContentControl | allow options set via appData to be seen by API calls |
classId Accessor ReadOnly | string | ViewportContentControl | Gets the class Id of configurable element |
controlId Accessor ReadOnly | string | ViewportContentControl | Returns the ID of this ConfigurableUiControl. |
isReady Accessor ReadOnly | Promise<void> | ViewportContentControl | Returns a promise that resolves when the control is ready for usage. |
isViewport Accessor ReadOnly | boolean | ViewportContentControl | Returns true if this control is a Viewport control. |
name Accessor ReadOnly | string | ViewportContentControl | Get internal name of configurable element. If no name is defined in configuration then the name will match the UniqueId. |
navigationAidControl Accessor ReadOnly | string | ViewportContentControl | Get the NavigationAidControl associated with this ContentControl |
supportsViewSelectorChange Accessor ReadOnly | boolean | ViewportContentControl | Returns true if this control supports processing ViewSelector changes. |
viewport Accessor | undefined | ScreenViewport | ViewportContentControl | The underlying ScreenViewport |
Defined in
Last Updated: 20 June, 2023