Action<T extends string> Interface
A basic Redux Action.
Technically, redux only requires actions to have a type
property.
We use a TypeScript Generic interface here to preserve the "literal-ness" of the type
property.
In other words, Action<"FOO">
will be of type { type: "FOO" }
; it won't be simplified to { type: string }
.
See the TS Handbook for more info on TypeScript string literal types.
Properties
Name | Type | Description | |
---|---|---|---|
type | T |
Defined in
Last Updated: 20 June, 2023