ModelessDialogProps Interface
Properties for the ModelessDialog component
Extends
Inherited methods
Name |
Inherited from |
Description |
onClose(): void Optional |
DialogProps |
onClick event for X button for dialog |
onEscape(): void Optional |
DialogProps |
'keyup' event for Esc key |
onModelessPointerDown(event: PointerEvent<Element>, id: string): void Optional |
DialogProps |
Pointer Down event handler when modeless (modal = false) |
onOutsideClick(event: MouseEvent): any Optional |
DialogProps |
Triggered when a click is triggered outside of this dialog. |
Properties
Name |
Type |
Description |
|
dialogId |
string |
|
|
movable |
undefined | boolean |
|
|
Inherited properties
Name |
Type |
Inherited from |
Description |
alignment |
undefined | DialogAlignment |
DialogProps |
Default alignment of dialog. |
backgroundStyle |
undefined | CSSProperties |
DialogProps |
Custom CSS Style for overlay |
buttonCluster |
undefined | DialogButtonDef[] |
DialogProps |
List of DialogButtonDef objects specifying buttons and associated onClick events |
contentClassName |
undefined | string |
DialogProps |
Custom CSS class name for the content |
contentStyle |
undefined | CSSProperties |
DialogProps |
Custom CSS Style for the content |
string | Element |
DialogProps |
Footer to show at bottom of dialog. |
undefined | CSSProperties |
DialogProps |
Custom CSS Style for footer |
undefined | ReactNode |
DialogProps |
Override for the header |
height |
string | number |
DialogProps |
Initial height of dialog. |
undefined | boolean |
DialogProps |
Whether the hide the header. |
inset |
undefined | boolean |
DialogProps |
Indicates whether the content should be inset. |
itemId |
undefined | string |
DialogProps |
Optional unique identifier for item. |
maxHeight |
string | number |
DialogProps |
Maximum height that the dialog may be resized to. |
maxWidth |
string | number |
DialogProps |
Maximum width that the dialog may be resized to. |
minHeight |
string | number |
DialogProps |
Minimum height that the dialog may be resized to. |
minWidth |
string | number |
DialogProps |
Minimum width that the dialog may be resized to. |
modal |
undefined | boolean |
DialogProps |
Whether to show background overlay. |
modelessId |
undefined | string |
DialogProps |
An id for a modeless dialog |
opened |
boolean |
DialogProps |
Indicates whether to show dialog or not |
resizable |
undefined | boolean |
DialogProps |
Indicates whether the user can resize dialog with cursor. |
title |
string | Element |
DialogProps |
Title to show in title bar of dialog |
titleStyle |
undefined | CSSProperties |
DialogProps |
Custom CSS Style for title |
trapFocus |
undefined | boolean |
DialogProps |
Indicates whether the focus should be trapped within the dialog. |
width |
string | number |
DialogProps |
Initial width of dialog. |
x |
undefined | number |
DialogProps |
Initial x/left position of dialog in px. |
y |
undefined | number |
DialogProps |
Initial y/top position of dialog in px. |
Defined in
Last Updated:
20 June, 2023