FrontstageManager Class
Deprecated in 3.7. Use UiFramework.frontstages
property.
Frontstage Manager class.
Methods
Name | Description | |
---|---|---|
constructor(): FrontstageManager | ||
addFrontstageProvider(frontstageProvider: FrontstageProvider): void Static | Add a Frontstage via a FrontstageProvider. | |
clearFrontstageDefs(): void Static | Clears the Frontstage map. | |
clearFrontstageProviders(): void Static | Clears the Frontstage Providers and the defs that may have been created from them. | |
closeModalFrontstage(): void Static | Closes the top-most modal Frontstage. | |
closeNestedFrontstage(): Promise<void> Static | Closes the top-most nested Frontstage. | |
deactivateFrontstageDef(): Promise<void> Static | Deactivates the active FrontstageDef. | |
findWidget(widgetId: string): undefined | WidgetDef Static | Finds a widget with the given id in the active frontstage | |
getFrontstageDef(id?: string): Promise<undefined | FrontstageDef> Static | Find a loaded Frontstage with a given id. | |
hasFrontstage(frontstageId: string): boolean Static | ||
initialize(): void Static | Initializes the InternalFrontstageManager | Deprecated |
openModalFrontstage(modalFrontstage: ModalFrontstageInfo): void Static | Opens a modal Frontstage. | |
openNestedFrontstage(nestedFrontstage: FrontstageDef): Promise<void> Static | Opens a nested Frontstage. | |
setActiveContentGroup(contentGroup: ContentGroup): Promise<void> Static | Sets the active layout, content group and active content. | |
setActiveFrontstage(frontstageId: string): Promise<void> Static | Sets the active FrontstageDef give the stageId. | |
setActiveFrontstageDef(frontstageDef: undefined | FrontstageDef): Promise<void> Static | Sets the active FrontstageDef. | |
setActiveLayout(contentLayoutDef: ContentLayoutDef, contentGroup: ContentGroup): Promise<void> Static | Sets the active layout, content group and active content. | |
setActiveNavigationAid(navigationAidId: string, iModelConnection: IModelConnection): void Static | Sets the active Navigation Aid via its Id. | |
setActiveTool(tool: Tool): void Static | Sets the active tool | |
setActiveToolId(toolId: string): void Static | Sets the active tool id | |
setWidgetState(widgetId: string, state: WidgetState): boolean Static | Sets the state of the widget with the given id | |
updateModalFrontstage(): void Static | Updates the top-most modal Frontstage. |
Properties
Name | Type | Description | |
---|---|---|---|
activeFrontstageDef Accessor StaticReadOnly | undefined | FrontstageDef | Gets the active FrontstageDef. | |
activeFrontstageId Accessor StaticReadOnly | string | Gets the Id of the active FrontstageDef. | |
activeModalFrontstage Accessor StaticReadOnly | undefined | ModalFrontstageInfo | Gets the top-most modal Frontstage. | |
activeNestedFrontstage Accessor StaticReadOnly | undefined | FrontstageDef | Gets the top-most nested Frontstage. | |
activeToolId Accessor StaticReadOnly | string | Gets the Id of the active tool. | |
activeToolInformation Accessor StaticReadOnly | undefined | ToolInformation | Gets the active tool's ToolInformation | |
isLoading Accessor StaticReadOnly | boolean | Returns true if Frontstage is loading its controls. | |
modalFrontstageCount Accessor StaticReadOnly | number | Gets the number of modal Frontstages. | |
nestedFrontstageCount Accessor StaticReadOnly | number | Gets the number of nested Frontstages. | |
NineZoneManager Accessor StaticReadOnly | NineZoneManager | Get Nine-zone State Manager. | |
onContentControlActivatedEvent Accessor StaticReadOnly | ContentControlActivatedEvent | Get Content Control Activated event. | |
onContentLayoutActivatedEvent Accessor StaticReadOnly | ContentLayoutActivatedEvent | Get Content Layout Activated event. | |
onFrontstageActivatedEvent Accessor StaticReadOnly | FrontstageActivatedEvent | Get Frontstage Activated event. | |
onFrontstageDeactivatedEvent Accessor StaticReadOnly | FrontstageDeactivatedEvent | Get Frontstage Deactivated event. | |
onFrontstageReadyEvent Accessor StaticReadOnly | FrontstageReadyEvent | Get Frontstage Activated event. | |
onModalFrontstageChangedEvent Accessor StaticReadOnly | ModalFrontstageChangedEvent | Get Modal Frontstage Changed event. | |
onModalFrontstageClosedEvent Accessor StaticReadOnly | ModalFrontstageClosedEvent | Get Modal Frontstage Closed event. | |
onNavigationAidActivatedEvent Accessor StaticReadOnly | NavigationAidActivatedEvent | Get Navigation Aid Activated event. | |
onToolActivatedEvent Accessor StaticReadOnly | ToolActivatedEvent | Get Tool Activated event. | |
onToolIconChangedEvent Accessor StaticReadOnly | ToolIconChangedEvent | Get Tool Icon Changed event. | |
onToolSettingsReloadEvent Accessor StaticReadOnly | UiEvent<void> | Get ToolSetting Reload event. | |
onWidgetStateChangedEvent Accessor StaticReadOnly | WidgetStateChangedEvent | Get Widget State Changed event. |
Defined in
Last Updated: 20 June, 2023