ContentGroup Class
ContentGroup class. Content Groups define content displayed in content views that are laid out using a ContentLayout.
Methods
Name | Description | |
---|---|---|
constructor(contentGroupProps: ContentGroupProps): ContentGroup | ||
clearContentControls(): void | Clears the map of content controls. | |
getContentControl(contentProps: ContentProps, _index: number): undefined | ContentControl | Gets a ContentControl from the Content Group based on its ContentProps. | |
getContentControlById(id: string): undefined | ContentControl | Gets a ContentControl from the Content Group with a given ID. | |
getContentControls(): ContentControl[] | Gets an array of the content controls representing the Content Views. | |
getContentNodes(): ReactNode[] | Gets the React nodes representing the Content Views in this Content Group. | |
getControlFromElement(node: ReactNode): undefined | ContentControl | Gets the ContentControl associated with a given React node representing a Content View. | |
onFrontstageDeactivated(): void | Called when Frontstage is deactivated. | |
onFrontstageReady(): void | Called when Frontstage is ready. | |
refreshContentNodes(): void | Refreshes the React nodes representing the Content Views in this Content Group.. | |
toJSON(contentCallback?: ContentCallback): ContentGroupProps | Creates ContentGroupProps for JSON purposes |
Properties
Name | Type | Description | |
---|---|---|---|
contentPropsList | ContentProps[] | ||
groupId | string | ||
id Accessor ReadOnly | string | ||
layout | ContentLayoutProps | ||
propsId | string |
Defined in
Last Updated: 20 June, 2023