ContentControl Class
The base class for Frontstage content controls.
Extends
Extended by
Methods
Name | Description | |
---|---|---|
constructor(info: ConfigurableCreateInfo, options: any): ContentControl | Creates an instance of ContentControl. | |
getKeyedReactNode(): ReactNode Protected | ||
getReactNode(): ReactNode Protected | ||
getType(): ConfigurableUiControlType | Gets the type of ConfigurableUiControl, which is 'Content' in this case | |
onActivated(): void | Called when this ContentControl is activated | |
onDeactivated(): void | Called when this ContentControl is deactivated |
Inherited methods
Name | Inherited from | Description |
---|---|---|
onFrontstageDeactivated(): void | ConfigurableUiControl | Called when Frontstage is deactivated. |
onFrontstageReady(): void | ConfigurableUiControl | Called when Frontstage is ready. |
onInitialize(): void | ConfigurableUiControl | Called to initialize the ConfigurableUiControl. |
Properties
Name | Type | Description | |
---|---|---|---|
_reactNode Protected | ReactNode | ||
isViewport Accessor ReadOnly | boolean | Returns true if this control is a Viewport control. | |
navigationAidControl Accessor ReadOnly | string | Get the NavigationAidControl associated with this ContentControl | |
reactNode Accessor | ReactNode | The React node associated with this control. | |
viewport Accessor ReadOnly | undefined | ScreenViewport | Returns the ScreenViewport if isViewport is true |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
_appDataOptions Protected | any | ConfigurableUiControl | |
applicationData Accessor ReadOnly | any | ConfigurableUiControl | allow options set via appData to be seen by API calls |
classId Accessor ReadOnly | string | ConfigurableUiControl | Gets the class Id of configurable element |
controlId Accessor ReadOnly | string | ConfigurableUiControl | Returns the ID of this ConfigurableUiControl. |
isReady Accessor ReadOnly | Promise<void> | ConfigurableUiControl | Returns a promise that resolves when the control is ready for usage. |
name Accessor ReadOnly | string | ConfigurableUiControl | Get internal name of configurable element. If no name is defined in configuration then the name will match the UniqueId. |
Defined in
Last Updated: 20 June, 2023