ConfigurableUiControl Class
The abstract base class for all Frontstage controls.
note This is an abstract class which should not be derived from by the applications. Instead, applications should derive from one of ContentControl, ViewportContentControl, WidgetControl, StatusBarWidgetControl or NavigationAidControl.
Extends
Extended by
Methods
Name | Description | |
---|---|---|
constructor(info: ConfigurableCreateInfo, options: any): ConfigurableUiControl | Creates an instance of ConfigurableUiControl. | |
getType(): ConfigurableUiControlType Abstract | Get the type of this control. | |
onFrontstageDeactivated(): void | Called when Frontstage is deactivated. | |
onFrontstageReady(): void | Called when Frontstage is ready. | |
onInitialize(): void | Called to initialize the ConfigurableUiControl. |
Properties
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
_appDataOptions Protected | any | ConfigurableBase | |
applicationData Accessor ReadOnly | any | ConfigurableBase | allow options set via appData to be seen by API calls |
classId Accessor ReadOnly | string | ConfigurableBase | Gets the class Id of configurable element |
name Accessor ReadOnly | string | ConfigurableBase | Get internal name of configurable element. If no name is defined in configuration then the name will match the UniqueId. |
Defined in
Last Updated: 20 June, 2023