ToolUiProvider Class
ToolUiProvider provides the Tool Settings and/or Tool Assistance UI for a tool. The ToolUiProvider is registered for the tool id via UiFramework.controls.register.
Extends
Methods
Name | Description | |
---|---|---|
constructor(info: ConfigurableCreateInfo, options: any): ToolUiProvider | Creates an instance of ConfigurableUiControl. | |
getType(): ConfigurableUiControlType | Gets the type of ConfigurableUiControl, which is 'ToolUiProvider' in this case | |
reloadPropertiesFromTool(): void | ||
syncToolSettingsProperties(_args: SyncToolSettingsPropertiesEventArgs): void |
Inherited methods
Name | Inherited from | Description |
---|---|---|
onFrontstageDeactivated(): void | ConfigurableUiControl | Called when Frontstage is deactivated. |
onFrontstageReady(): void | ConfigurableUiControl | Called when Frontstage is ready. |
onInitialize(): void | ConfigurableUiControl | Called to initialize the ConfigurableUiControl. |
Properties
Name | Type | Description | |
---|---|---|---|
_dataProvider Protected | undefined | UiDataProvider | ||
dataProvider Accessor | undefined | UiDataProvider | The UiDataProvider class | |
horizontalToolSettingNodes Accessor | undefined | ToolSettingsEntry[] | An array of entries to load into the horizontal tool settings | |
toolSettingsNode Accessor | ReactNode | A React node that holds tool settings when shown in a rectangular area (i.e. | |
uniqueId Accessor ReadOnly | string |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
_appDataOptions Protected | any | ConfigurableUiControl | |
applicationData Accessor ReadOnly | any | ConfigurableUiControl | allow options set via appData to be seen by API calls |
classId Accessor ReadOnly | string | ConfigurableUiControl | Gets the class Id of configurable element |
controlId Accessor ReadOnly | string | ConfigurableUiControl | Returns the ID of this ConfigurableUiControl. |
isReady Accessor ReadOnly | Promise<void> | ConfigurableUiControl | Returns a promise that resolves when the control is ready for usage. |
name Accessor ReadOnly | string | ConfigurableUiControl | Get internal name of configurable element. If no name is defined in configuration then the name will match the UniqueId. |
Defined in
Last Updated: 20 June, 2023