StatusBarWidgetControl Class
Status Bar Widget Control.
Extends
Extended by
Methods
Name | Description | |
---|---|---|
constructor(info: ConfigurableCreateInfo, options: any): StatusBarWidgetControl | Creates an instance of ConfigurableUiControl. | |
getReactNode(args: StatusBarWidgetControlArgs): ReactNode Abstract | Gets the React node associated with this StatusBar Widget Control | |
getType(): ConfigurableUiControlType | Gets the type of ConfigurableUiControl, which is 'StatusBarWidget' in this case |
Inherited methods
Name | Inherited from | Description |
---|---|---|
onFrontstageDeactivated(): void | WidgetControl | Called when Frontstage is deactivated. |
onFrontstageReady(): void | WidgetControl | Called when Frontstage is ready. |
onInitialize(): void | WidgetControl | Called to initialize the ConfigurableUiControl. |
onWidgetStateChanged(): void | WidgetControl | Called when widget state changes. |
restoreTransientState(): boolean | WidgetControl | Overwrite to restore transient DOM state. |
saveTransientState(): void | WidgetControl | Overwrite to save transient DOM state (i.e. |
setWidgetState(state: WidgetState): void | WidgetControl | Sets the WidgetState for this control |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
_appDataOptions Protected | any | WidgetControl | |
applicationData Accessor ReadOnly | any | WidgetControl | allow options set via appData to be seen by API calls |
classId Accessor ReadOnly | string | WidgetControl | Gets the class Id of configurable element |
controlId Accessor ReadOnly | string | WidgetControl | Returns the ID of this ConfigurableUiControl. |
isReady Accessor ReadOnly | Promise<void> | WidgetControl | Returns a promise that resolves when the control is ready for usage. |
name Accessor ReadOnly | string | WidgetControl | Get internal name of configurable element. If no name is defined in configuration then the name will match the UniqueId. |
reactNode Accessor | ReactNode | WidgetControl | The ReactNode associated with this control |
widgetDef Accessor | WidgetDef | WidgetControl | The WidgetDef associated with this control |
Defined in
Last Updated: 20 June, 2023