StatusBarWidgetComposerControl Class
StatusBarWidgetComposerControl provides status bar to specified Frontstage that allows status bar items to be populated via UiItemsProviders. See StandardStatusbarItemsProvider that can be used to populate this status bar with a common set of status fields.
example
statusBar={
<Zone
widgets={
[
<Widget isStatusBar={true} control={StatusBarWidgetComposerControl} />
]}
/>
}
Extends
Methods
Name | Description | |
---|---|---|
constructor(info: ConfigurableCreateInfo, options: any): StatusBarWidgetComposerControl | Creates an instance of ConfigurableUiControl. | |
getReactNode(): ReactNode | Gets the React node associated with this StatusBar Widget Control |
Inherited methods
Name | Inherited from | Description |
---|---|---|
getType(): ConfigurableUiControlType | StatusBarWidgetControl | Gets the type of ConfigurableUiControl, which is 'StatusBarWidget' in this case |
onFrontstageDeactivated(): void | StatusBarWidgetControl | Called when Frontstage is deactivated. |
onFrontstageReady(): void | StatusBarWidgetControl | Called when Frontstage is ready. |
onInitialize(): void | StatusBarWidgetControl | Called to initialize the ConfigurableUiControl. |
onWidgetStateChanged(): void | StatusBarWidgetControl | Called when widget state changes. |
restoreTransientState(): boolean | StatusBarWidgetControl | Overwrite to restore transient DOM state. |
saveTransientState(): void | StatusBarWidgetControl | Overwrite to save transient DOM state (i.e. |
setWidgetState(state: WidgetState): void | StatusBarWidgetControl | Sets the WidgetState for this control |
Properties
Name | Type | Description | |
---|---|---|---|
controlId Static | string | ||
id Readonly | string |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
_appDataOptions Protected | any | StatusBarWidgetControl | |
applicationData Accessor ReadOnly | any | StatusBarWidgetControl | allow options set via appData to be seen by API calls |
classId Accessor ReadOnly | string | StatusBarWidgetControl | Gets the class Id of configurable element |
controlId Accessor ReadOnly | string | StatusBarWidgetControl | Returns the ID of this ConfigurableUiControl. |
isReady Accessor ReadOnly | Promise<void> | StatusBarWidgetControl | Returns a promise that resolves when the control is ready for usage. |
name Accessor ReadOnly | string | StatusBarWidgetControl | Get internal name of configurable element. If no name is defined in configuration then the name will match the UniqueId. |
reactNode Accessor | ReactNode | StatusBarWidgetControl | The ReactNode associated with this control |
widgetDef Accessor | WidgetDef | StatusBarWidgetControl | The WidgetDef associated with this control |
Defined in
Last Updated: 20 June, 2023