withStatusFieldProps Function
Deprecated in 3.3. StatusFieldProps props are deprecated, using this is no longer necessary and will be removed.
HOC that injects values for StatusFieldProps.
withStatusFieldProps<P extends StatusFieldProps, C>(Component: (props: P) => | ReactElement<any, any> & C & (props: P) => Component<any, any, any> & C): (props: LibraryManagedAttributes<C, Omit<P, "isInFooterMode" | "onOpenWidget" | "openWidget">>) => Element
Parameter | Type | Description |
---|---|---|
Component | (props: P) => | ReactElement<any, any> & C & (props: P) => Component<any, any, any> & C |
Returns - (props: LibraryManagedAttributes<C, Omit<P, "isInFooterMode" | "onOpenWidget" | "openWidget">>) => Element
Defined in
Last Updated: 20 June, 2023